Bug 459236 - Revisor fails to build a large system (The virtual filesystem is too small)
Revisor fails to build a large system (The virtual filesystem is too small)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
9
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 04:59 EDT by Sebastian Nielsen
Modified: 2009-05-31 06:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 06:57:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the kickstart used to create the system. (5.92 KB, text/plain)
2008-08-15 04:59 EDT, Sebastian Nielsen
no flags Details
Log file outputted with "revisor --debug 9 > ./revisorlog.log" (393.53 KB, text/plain)
2008-08-15 05:00 EDT, Sebastian Nielsen
no flags Details
A terminal log file, showing a few error message not outputted to revisorlog.log (323 bytes, text/plain)
2008-08-15 05:01 EDT, Sebastian Nielsen
no flags Details

  None (edit)
Description Sebastian Nielsen 2008-08-15 04:59:18 EDT
Created attachment 314382 [details]
the kickstart used to create the system.

When creating a large livecd, probably about 6000-7000 MB, revisor tells me it cannot install the packages due to not enough space on the filesystem /var/tmp/revisor.
(see revisorlog.log for a full --debug 9 output)
In english, the error message in bottom of revisorlog.log is "Installation of package #packagename# requires #size# MB on filesystem /var/tmp/revisor"
(Where #packagename# is the name of package and #size# is the required size)

When using "part / --size 20000" as told by one of the revisor developers in kickstart, I get some messages in terminal (see terminal.log)
The error messages in english is:
umount: /var/tmp/revisor: Device is busy.
umount: /var/tmp/revisor: Device is busy.
ioctl: LOOP_CLR_FD: Device or resource busy.
Comment 1 Sebastian Nielsen 2008-08-15 05:00:47 EDT
Created attachment 314383 [details]
Log file outputted with "revisor --debug 9 > ./revisorlog.log"
Comment 2 Sebastian Nielsen 2008-08-15 05:01:41 EDT
Created attachment 314384 [details]
A terminal log file, showing a few error message not outputted to revisorlog.log
Comment 3 Sebastian Nielsen 2008-08-15 11:18:14 EDT
Ill change this to Urgent since this bug makes Revisor unuseable for larger projects.
Comment 4 Jeroen van Meeuwen 2008-10-19 07:30:54 EDT
What version of Revisor is this, as I'm unable to reproduce this behavour using the latest version, 2.1.1-7
Comment 5 Sebastian Nielsen 2008-10-19 09:17:41 EDT
I was using the latest version available when this bug was submitted. In other words, 2.1.1-6.

Has this been fixed in version 2.1.1-7?
Comment 6 Fedora Admin XMLRPC Client 2009-01-31 19:05:51 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Jeroen van Meeuwen 2009-05-31 06:57:16 EDT
2.1.4 is out now, and I haven't had any problems building large optical live media. Can you retest / reopen if necessary?

Note You need to log in before you can comment on or make changes to this bug.