Bug 459275 - at-spi spewing incessant useless warnings to stderr, filling up disk
at-spi spewing incessant useless warnings to stderr, filling up disk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 12:16 EDT by Jarod Wilson
Modified: 2008-08-23 19:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 19:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2008-08-15 12:16:05 EDT
Description of problem:
Looks like at-spi is stupidly spewing some warning messages to stderr, which winds up dumping them into ~/.xsession-errors. One particular error...

(gnome-terminal:3616): atk-bridge-WARNING **: failure: no device event controller found.

...has been repeating over and over and over and over, to the tune of a 43G ~/.xsession-errors file on my laptop in a mere day and a half of uptime.

Looks like the culprit is somewhere in libatk-bridge.so.


Version-Release number of selected component (if applicable):
at-spi-1.23.6-1.fc10


How reproducible:
not exactly sure. I don't actually *use* any of this accessibility stuff...
Comment 1 Jarod Wilson 2008-08-15 13:52:53 EDT
I think this might do the trick:

--- at-spi-1.23.6.orig/atk-bridge/bridge.c	2008-08-15 13:23:16.000000000 -0400
+++ at-spi-1.23.6/atk-bridge/bridge.c	2008-08-15 13:26:15.000000000 -0400
@@ -470,7 +470,7 @@ spi_atk_bridget_get_dec (void)
 
   if (BONOBO_EX (&ev))
     {
-      g_warning (_("failure: no device event controller found.\n"));
+      DBG (1, g_warning (_("failure: no device event controller found.\n")));
       registry_died = TRUE;
       device_event_controller = CORBA_OBJECT_NIL;
     }
Comment 2 Matthias Clasen 2008-08-15 14:20:50 EDT
That looks fine, feel free to put that patch into rawhide or where you need it when koji comes back.
Comment 3 Matthias Clasen 2008-08-15 14:23:11 EDT
Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=547943
Comment 4 Jarod Wilson 2008-08-20 09:35:13 EDT
Okay, patch has been added to rawhide and at-spi-1.23.6-2.fc10 has been tagged. Build hosts still offline though.
Comment 5 Matthias Clasen 2008-08-23 19:36:58 EDT
I've built it now

Note You need to log in before you can comment on or make changes to this bug.