Bug 459292 - satsync custom channel (fedora9) fails w/ bad error
satsync custom channel (fedora9) fails w/ bad error
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
na
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-08-15 15:01 EDT by wes hayutin
Modified: 2008-09-26 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 15:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-08-15 15:01:43 EDT
Description of problem:

ERROR: you are not entitled to sync a channel in this set of channels.
Please contact your sales rep or RHN contact
fedora9

k.. this is a custom channel, spacewalk should not care what the entitlement is..

recreate..
1. rhnpush fedora 9 content into a channel
2. export the channel
3. remove the channel from the sat. w/ script or schema refresh
4. satsync the exported channel
ie.. satellite-sync -c fedora9 -m /export


14:48:47 Retrieving / parsing arches data
14:48:47 arches data complete
14:48:47 
14:48:47 Retrieving / parsing additional arches data
14:48:47 additional arches data complete
14:48:47 
14:48:47 Retrieving / parsing channel data
14:48:47    p = previously imported/synced channel
14:48:47    . = channel not yet imported/synced
14:48:47    base-channels:
14:48:47       . fedora9                                  9893
14:48:47 
+++ sending log as an email +++

SYNC ERROR:

(Check logs/email for potentially more detail)


ERROR: you are not entitled to sync a channel in this set of channels.
Please contact your sales rep or RHN contact
fedora9

[root@rlx-3-18 ~]$ 


k.. this is a custom channel
Comment 1 Devan Goodwin 2008-09-05 10:50:11 EDT
Bumping to space03.
Comment 2 Pradeep Kilambi 2008-09-26 15:26:19 EDT
This is because a custom channel still cares about a private-channel-family. I fixed exporter in spacewalk 0.2(latest pkg builds) to create private-channel-family for that org so it does'nt give this error. 

Please try this on a freshly installed spacewlak 0.2 and lemme know. 

But for now closing as current release

Note You need to log in before you can comment on or make changes to this bug.