Bug 45930 - X application RPMs should depend on XFree86-libs, not Xfree86 itself
X application RPMs should depend on XFree86-libs, not Xfree86 itself
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 18:13 EDT by Matthew Saltzman
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 00:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2001-06-25 18:13:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
XFree86-libs was broken out of the main XFree86 package so that X apps
living on a server could be run remotely without installing XFree86 itself
and supporting packages 
on the server.  But many X app RPMs still depend (possibly indirectly) on
XFree86.

How reproducible:
Always

Steps to Reproduce:
1. Run installer
2. Select GUI configurators (e.g. printconf or firewall-config) but don't
select XFree86. 
(I don't recall the exact packages at this point, but it happened several
times.  Bottom line, no GUI configurators.)
3. Allow dependency packages to be loaded.
4. Repeat until XFree86, font libraries, etc., are required.
	

Actual Results:  Could not install GUI configurators without hitting
dependency on XFree86.

Expected Results:  Ideally, should be able to install any X app (especially
GUI config tools) on a machine with XFree86-libs, even if it doesn't have
XFree86.

Additional info:

This feature is desirable for building firewalls (where firewall-config
would be useful) on legacy hardware (where XFree86 won't fit) or headless
compute servers.  Configuration could certainly be done remotely in these
cases *if* the tools could be installed.

Many of the dependency paths seem to lead through control-panel.
Comment 1 Mike A. Harris 2001-06-30 06:00:00 EDT
All known issues WRT dependancy breakageness have been fixed in rawhide
since around May 4th.  You can get the packages from my ftp space at:

ftp://people.redhat.com/mharris/testing

Thanks for the heads up though, and please do report any further problems
like this as I want to make the packaging as painless for people as possible.
Comment 2 Mike A. Harris 2001-06-30 06:01:51 EDT
BTW, release 4.0.3-14 is the one that contained the last fixes to this,
so every release since then has had them.  They should be fully compatible
to install.  You will need Mesa and glibc updates though to use.

Note You need to log in before you can comment on or make changes to this bug.