Bug 459305 - %lang tagging
%lang tagging
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgweather (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Winship
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 17:43 EDT by Matthias Clasen
Modified: 2008-10-14 14:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 14:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
%lang'ify Locations.*.xml (1.34 KB, patch)
2008-08-22 14:38 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2008-08-15 17:43:49 EDT
Now that libgweather ships the xml split per language (yay !), it would be a nice touch to add proper %lang tags to the file list, so that hypothetical localized spins can reap the benefits of the split. Actually, it may already benefit our regular livecd spin, since that also uses a reduced list of supported languages.
Comment 1 Ville Skyttä 2008-08-22 14:38:35 EDT
Created attachment 314827 [details]
%lang'ify Locations.*.xml

Incidentally, I did this about a week ago, see attached patch.

It also contains an unrelated hunk which moves xsltproc from %install to %build where it is IMO better placed, as well as uses xmllint --noblanks to do the whitespace reduction which also feels better than editing XML with sed (although it's pretty trivial in this case).
Comment 2 Dan Winship 2008-08-22 15:43:34 EDT
Ah, cool. I tried to do this earlier in the week, but no cvs...

I don't really know rpmspec-ese, so I can't say if this is right, although just looking at the diff, I think this part:

+xsltproc %{SOURCE1} data/Locations.xml > data/loc.xml
+xmllint --noblanks data/loc.xml > data/Locations.xml

(which you moved from install-time to make-time) is irrelevant now, because libgweather does --noblanks itself in 2.24.
Comment 3 Ville Skyttä 2008-08-23 05:18:33 EDT
Seems so indeed, already in 2.23.6.
Comment 4 Dan Winship 2008-10-14 14:02:44 EDT
Matthias committed this a while ago

Note You need to log in before you can comment on or make changes to this bug.