Bug 459307 - kernel-devel missing uvcvideo.h
kernel-devel missing uvcvideo.h
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 19:39 EDT by Jeff Moe (jebba)
Modified: 2010-07-18 09:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-18 09:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2008-08-15 19:39:27 EDT
Description of problem:
Fedora kernel-devel as of 2.6.26 (in F9 koji) and 2.6.27 in current rawhide are missing the uvcvideo.h file.

Version-Release number of selected component (if applicable):
One example version, but I think it applies to all 2.6.26 and 2.6.27:
2.6.27-0.244.rc2.git1.fc10


How reproducible:
This shows no uvcvideo.h:
rpm -qpl kernel-devel-2.6.27-0.244.rc2.git1.fc10.i686.rpm kernel-headers-2.6.27-0.244.rc2.git1.fc10.i386.rpm | grep uvcvideo.h

This does have uvcvideo.h:
rpm -qpl kernel-devel-2.6.25.14-108.fc9.i686.rpm | grep uvcvideo.h
/usr/src/kernels/2.6.25.14-108.fc9.i686/include/config/usb/uvcvideo.h


Additional info:
In 2.6.25 uvcvideo was patched in. As of 2.6.26 it's upstream.
Comment 1 Kyle McMartin 2008-09-03 11:53:09 EDT
Just wondering what you need the kernel header for? None of the current v4l2 media drivers export their headers from the kernel.
Comment 2 Jeff Moe (jebba) 2008-09-03 12:20:17 EDT
I was trying to compile this:
http://www.quickcamteam.net/dev/libwebcam-0.1.1.tar.bz2

I'd have to hunt around to remember why I needed it, heh.

thx
Comment 3 Bug Zapper 2008-11-25 21:47:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Brian Pitts 2009-09-18 22:51:46 EDT
This bug is still present in the kernel-devel package for 2.6.30.5-43.fc11.x86_64. I also got here because I was trying to compile the code at http://svn.quickcamteam.net/svn/qct/Linux/
Comment 5 Bug Zapper 2009-11-18 03:16:33 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Brian Pitts 2009-12-05 19:24:53 EST
This bug is still present in Fedora 12's 2.6.31.5-127
Comment 7 Bug Zapper 2009-12-18 01:18:49 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 8 Jeff Moe (jebba) 2009-12-18 08:29:54 EST
Per comment #6, it's still missing in F12, re-opened.
Comment 9 Jeff Moe (jebba) 2010-04-21 19:23:05 EDT
libwebcam is getting packaged for Fedora. He's using a "Source1: uvcvideo.h" to work around the problem.

https://bugzilla.redhat.com/show_bug.cgi?id=576023

(fwiw, this time around I wanted it to do pan/tilt control of a camera.)
Comment 10 Chuck Ebbert 2010-05-08 22:07:31 EDT
It looks like uvcvideo.h needs to move to include/media/ in order to be exported.
Comment 11 Hans de Goede 2010-05-09 03:18:08 EDT
This is a known issue, which is being worked on upstream. I say worked on upstream, as there also are some API changes in the pipeline, which is why the
header file is not yet being installed (and thus the API made public) yet.
Comment 12 Hans de Goede 2010-07-18 09:48:59 EDT
Ok, so the one program suffering from this, libwebcam will become available in the repository soon (see bug #576023) and that uses its own copy of uvcvideo.h for now. libwebcam is the only one which should need uvcvideo.h as it manages the dynamic uvc controls for which it is needed.

Note that for pan / tilt control uvcvideo.h should NOT be used, instead uvcdynctrl should be installed which will then make the pan / tilt control show up as regular v4l2 controls.

As the missing of uvcvideo.h is not causing any issues atm, and this is being worked on upstream I'm going to close this bug with a resolution of upstream.

Note You need to log in before you can comment on or make changes to this bug.