Bug 459311 - Macbook Pro (4,1) + ndiswrapper + latest NetworkManager = CPU#0 stuck for 61s!
Macbook Pro (4,1) + ndiswrapper + latest NetworkManager = CPU#0 stuck for 61s!
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 20:41 EDT by Anderson Silva
Modified: 2008-08-18 10:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 02:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scrubbed message log (14.04 KB, application/octet-stream)
2008-08-15 20:46 EDT, Anderson Silva
no flags Details

  None (edit)
Description Anderson Silva 2008-08-15 20:41:59 EDT
Description of problem:

Connecting to a wireless network using the latest NetworkManager on Fedora 9 on my Macbook Pro (4,1). If I turn off NetworkManager, and use system-config-network, the computer doesn't freeze.

Version-Release number of selected component (if applicable):

[root@localhost tmp]# rpm -qa | grep NetworkManager
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc9.x86_64
NetworkManager-glib-0.7.0-0.9.4.svn3675.fc9.x86_64
NetworkManager-gnome-0.7.0-0.9.4.svn3675.fc9.x86_64
NetworkManager-0.7.0-0.9.4.svn3675.fc9.x86_64
NetworkManager-openvpn-0.7.0-14.svn3632.fc9.x86_64


How reproducible: It happens every time, sometimes it is almost instant, sometimes it takes a bit longer, like a minute or two.


Steps to Reproduce:
1. NetworkManager connects to SID
2. Start 'surfing'
3. Machine freezes
  
Actual results:

Machine locks up.

Expected results:

Machine doesn't lock up. :-)

Additional info:

part of my message log is attached.
Comment 1 Anderson Silva 2008-08-15 20:46:43 EDT
Created attachment 314425 [details]
scrubbed message log
Comment 2 Warren Togami 2008-08-16 02:50:26 EDT
@redhat.com?   You really should know better.

There is absolutely nothing we can do about ndiswrapper.  The Fedora kernel is not even capable of running with stability with ndiswrapper because you need 16KB stacks while Fedora kernel uses 4KB stacks for performance.
Comment 3 Anderson Silva 2008-08-16 08:02:25 EDT
wtogami@redhat.com you should read my post better. The problem is not ndiswrapper, it is NetworkManager, if the problem was ndiswrapper the dirvers wouldn't work even if I used system-config-network. So, instead of giving me attitude, why not just try to be helpful. If the bug won't be fixed, that's fine... just a shame that we have to keep shipping buggy software.
Comment 4 Anderson Silva 2008-08-16 08:47:23 EDT
I want to go on record and say a couple of things here:

1. I want to apologize for the 'buggy software' remark, software is complex, and virtually always there's going to be bugs on them with that said.

2. It's really hard not to get mad with remarks like:

"@redhat.com?   You really should know better."

Does everyone who work at red hat a kernel developer? It's very frustrating, because I know a lot of people in the Fedora community thrive to get people participating with the development with the OS with documentation, bug filing, packaging, development, etc...

Yet, I find myself asking if I will ever file a bug at bugzilla again due to the fact that I am expected to know the ins and outs of the operating system just because I work at redhat.com. Yes, I work there, yet that doesn't mean I know everything there is to know about the ins and outs of the operating system.

I will leave at that, I just hope that anyone who gets this email will be able to reflect upon how well are we treating Fedora users who are taking their personal time to contribute independent of where they work at.
Comment 5 Dan Williams 2008-08-18 09:37:02 EDT
If at any point your machine hangs or panics when using NetworkManager, that is a kernel or driver problem.  It's not NetworkManager's problem.  The kernel/driver should never panic or hang when asked to do anything.  NM uses wpa_supplicant to drive the wifi card, and the supplicant does a lot of things differently than system-config-network/iwconfig do precisely becuase it's more capable.  But that still means that if something panics or hangs, the kernel or driver are at fault here.

And because it's ndiswrapper, there's absolutely nothing we can do, because the driver is actually a closed-source Windows NDIS blob that we cannot fix :(

I feel your pain though, because there isn't a driver for the newer broadcom parts yet, and that sucks.
Comment 6 Anderson Silva 2008-08-18 10:01:42 EDT
dcbw@redhat.com, thank you for you explanation. sounds good.

AS

Note You need to log in before you can comment on or make changes to this bug.