Bug 459317 - ath5k does not work properly on oqo model 02 [NEEDINFO]
ath5k does not work properly on oqo model 02
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 04:53 EDT by Satish Mohan
Modified: 2009-12-18 01:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
linville: needinfo? (smohan)


Attachments (Terms of Use)

  None (edit)
Description Satish Mohan 2008-08-16 04:53:46 EDT
Description of problem:
ath5k does not work properly on oqo model 02

Version-Release number of selected component (if applicable):
2.6.27-0.244.rc2.git1.fc10.i686

How reproducible:
Boot oqo and attempt to use ath5k to connect to wireless network.

Steps to Reproduce:
1. Boot laptop
2. Attempt to connect to wireless network using ath5k
3. Try to browse websites

Actual results:
The driver does enable the adapter but throws error while trying to connect it to any access point. 

Expected results:
should be able to join wireless networks

Additional info:

03:04.0 Ethernet controller [0200]: Atheros Communications Inc. AR5413 802.11abg NIC [168c:001b] (rev 01)
	Subsystem: Atheros Communications Inc. Device [168c:1602]
	Flags: bus master, medium devsel, latency 168, IRQ 17
	Memory at c2100000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: [44] Power Management version 2
	Kernel driver in use: ath5k_pci
	Kernel modules: ath5k

[root@localhost ~]# iwconfig 
lo        no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11b  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

[root@localhost ~]# ifconfig wlan0 up
SIOCSIFFLAGS: Resource temporarily unavailable

[root@localhost ~]# dmesg | grep -i ath
ath5k_pci 0000:03:04.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k_pci 0000:03:04.0: registered as 'phy0'
ath5k phy0: Atheros AR5213A chip found (MAC: 0xf000c174, PHY: 0x0)
device-mapper: multipath: version 1.0.5 loaded
ath5k phy0: gain calibration timeout (2412MHz)
ath5k phy0: unable to reset hardware: -11
ath5k phy0: gain calibration timeout (2412MHz)
ath5k phy0: unable to reset hardware: -11
ath5k phy0: gain calibration timeout (2412MHz)
ath5k phy0: unable to reset hardware: -11
Comment 1 Christopher D. Stover 2008-10-28 16:28:48 EDT
Has this still been a problem for you in recent kernel releases Satish?
Comment 2 Satish Mohan 2008-11-10 06:58:45 EST
not working for me, tried with kernel-2.6.27.4-68.fc10
Comment 3 Bug Zapper 2008-11-25 21:47:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Satish Mohan 2009-01-30 02:08:40 EST
Issue seems to be triggered by via-agp module. Started working after i blacklisted via-agp. Will open another bug on via-agp
Comment 5 Andrew McNabb 2009-05-05 22:26:11 EDT
I've been having this problem intermittently after suspend/resume.  I am having this problem in Fedora 11 (Beta/Preview), but everything was working in Fedora 10.  I'm getting the same error messages:

ath5k phy0: can't reset hardware (-11)
ath5k phy0: gain calibration timeout (2432MHz)

I ran lsmod, and it doesn't look like via-agp is loaded.  I'll try blacklisting it anyway, though.
Comment 6 John W. Linville 2009-05-06 09:23:05 EDT
Could you try a 2.6.29-based kernel?

   yum --enablerepo=updates-testing update kernel

Does that change the behavior?
Comment 7 Andrew McNabb 2009-05-06 09:51:24 EDT
I have been having the problem with Fedora 11 Beta/Preview, which uses a 2.6.29 kernel.  Satish's report is for Fedora 10, so his experience may be different.
Comment 8 Stephen Fromm 2009-06-05 13:32:51 EDT
One more report for seeing this on F11, kernel-2.6.29.4-167.fc11.i586.  I typically see this after a few suspend/resume cycles.  This is on a Samsung n110.
Comment 9 Bug Zapper 2009-11-18 03:17:56 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Andrew McNabb 2009-11-18 11:20:50 EST
I'm still having problems after suspend/resume in Fedora 11, but the error messages have changed since Fedora 10 (I don't have that machine with me at the moment, but it's something like, 'disassociating by local choice').  Should this be a separate bug report?
Comment 11 Bug Zapper 2009-12-18 01:18:59 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.