Bug 459318 - audacious segfaults on startup
audacious segfaults on startup
Status: CLOSED DUPLICATE of bug 471868
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 06:22 EDT by Pierre Ossman
Modified: 2008-12-03 09:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 09:24:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball of configuration (250.00 KB, application/x-tar)
2008-08-16 12:40 EDT, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2008-08-16 06:22:34 EDT
Audacious is currently unusable as it crashes immediately on startup. Running gdb on it, the crash was seen in gdk_window_show():

Program received signal SIGSEGV, Segmentation fault.
0x08084ff1 in gdk_window_show () at gdkwindow.c:3526
3526	{
(gdb) bt
#0  0x08084ff1 in gdk_window_show () at gdkwindow.c:3526
#1  0x08085598 in gdk_window_show () at gdkwindow.c:3526
#2  0x080975f5 in gdk_window_show () at gdkwindow.c:3526
#3  0x0805a061 in gdk_window_show () at gdkwindow.c:3526
#4  0x46f826e5 in __libc_start_main () from /lib/libc.so.6
#5  0x08054551 in gdk_window_show () at gdkwindow.c:3526

Oddly enough, when I installed audacious-debuginfo, I got this instead:

Program received signal SIGSEGV, Segmentation fault.
0x08084ff1 in playlistwin_set_sinfo_font (font=0x817c298 "44100")
    at ui_playlist.c:311
311	    *strrchr(tmp, ' ') = '\0';
(gdb) bt
#0  0x08084ff1 in playlistwin_set_sinfo_font (font=0x817c298 "44100")
    at ui_playlist.c:311
#1  0x08085598 in playlistwin_create_widgets () at ui_playlist.c:1374
#2  playlistwin_create () at ui_playlist.c:1564
#3  0x080975f5 in init_skins (
    path=0x817c2e0 "/usr/share/audacious/Skins/Default") at ui_skin.c:527
#4  0x0805a061 in main (argc=1, argv=0xbffff524) at main.c:756
Comment 1 Ralf Ertzinger 2008-08-16 08:44:26 EDT
Works fine for me.

Can you try removing/renaming ~/.config/audacious and try again?
Do you have any files under ~/.local/share/audacious?
Comment 2 Pierre Ossman 2008-08-16 10:36:15 EDT
(In reply to comment #1)
> Works fine for me.
> 
> Can you try removing/renaming ~/.config/audacious and try again?

That makes it possible to start it again. It is something in my "config". Still, I'd consider it a pretty serious bug that the the config parser can segfault.

> Do you have any files under ~/.local/share/audacious?

Nope, just a directory structure.
Comment 3 Ralf Ertzinger 2008-08-16 11:58:45 EDT
If you still have the files under ~/.config/audacious, can you get me a tarball of them?
Comment 4 Pierre Ossman 2008-08-16 12:40:31 EDT
Created attachment 314435 [details]
tarball of configuration

Sure, here is the directory that causes audacious to crash.
Comment 5 Bug Zapper 2008-11-25 21:47:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Michael Schwendt 2008-12-03 09:24:20 EST
https://admin.fedoraproject.org/updates/F10/FEDORA-2008-10718

*** This bug has been marked as a duplicate of bug 471868 ***

Note You need to log in before you can comment on or make changes to this bug.