Bug 459333 - Apps don't respect font size settings in KDE
Apps don't respect font size settings in KDE
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 13:21 EDT by Hesty
Modified: 2008-09-28 17:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 17:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 171683 None None None Never

  None (edit)
Description Hesty 2008-08-16 13:21:01 EDT
Description of problem:
Using Fedora 9 as HTPC here, so font size has to be adjusted a bit bigger to accomodate reading from further away. So far, setting the font size in KDE's system settings (e.g. set all font size to 18) is not picked up for all apps tested. For example:
1. Konsole: still uses tiny fonts, even though the font size in profile setting says it's already 18. Ironically, the font size 18 is displayed correctly when konsole is started in Gnome.
2. Amarok: all the fonts inside the app (other than title bar) is small. Again, if amarok is started in Gnome, the font settings are used.
3. Firefox: all the title fonts, tab title fonts are small.

Version-Release number of selected component (if applicable):
Found in kde 4.1 from updates-testing, but also happened in kde 4.0

How reproducible:
Always.

Steps to Reproduce:
1. Use KDE.
2. Set font size in System Settings to something big.
3. Start any app.
  
Actual results:
Other than windows title, taskbar title, all fonts inside the app doesn't obey the font size setting.

Expected results:
Nice and big fonts.

Additional info:
Comment 1 Kevin Kofler 2008-08-16 13:27:53 EDT
Could this actually be an issue with DPI settings rather than font size settings? Effective font size is what a wrong DPI is mainly perceived as, but that's because the effective font size is a result of the used font size and the DPI setting.

What Qt style are you using? The default (Oxygen)? Or something else? (What?)
Comment 2 Kevin Kofler 2008-08-16 13:29:38 EDT
(By the way, I have noticed some bizarre behavior with effective font sizes (probably DPI) on my laptop too, I've yet to figure out what's going wrong.)
Comment 3 Hesty 2008-08-16 15:37:42 EDT
I'll check the DPI setting later. It didn't matter what style I used, I'm sure I've tried both Oxygen and Plastique and the same problem exists.
Comment 4 Rex Dieter 2008-08-16 16:07:18 EDT
Seems the font size is often a per-app preference.  For example, most kde apps I tried behaved as expected.  konsole being the exception, but I had previously modified the default font prefs there.

firefox, thunderbird did not respect fonts here and I'd suspect most other gnome apps may well not either, they (seem to) have their own mechanism for prefs like that.
Comment 5 Steven M. Parrish 2008-08-26 09:47:04 EDT
So it sounds like this is all working as designed and is not bug.  If that is the case can we close this?
Comment 6 Kevin Kofler 2008-08-26 10:06:03 EDT
No. When the same app randomly uses a smaller or larger "font" (probably DPI, actually), both within a KDE 4 session, that is definitely not "working as designed".
Comment 7 Steven M. Parrish 2008-09-25 19:22:03 EDT
Thanks for the report.  I checked upstream and could not find a matching bug.Please file a bug report in the the upstream bugzilla located at http://bugs.kde.org for the particular component involved.

Once you've filed your bug report to the upstream bugzilla, please add the upstream info to this report. We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 8 Hesty 2008-09-26 02:24:21 EDT
Entered the bug in upstream provider as bug 171683. Direct link is https://bugs.kde.org/show_bug.cgi?id=171683
Comment 9 Steven M. Parrish 2008-09-28 17:09:05 EDT
We found that this bug has been already registered in the upstream database (https://bugs.kde.org/show_bug.cgi?id=171683) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.