Bug 459346 - Totem removes get parameters from url before passing it to gstreamer
Totem removes get parameters from url before passing it to gstreamer
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-08-17 02:56 EDT by Hans de Goede
Modified: 2008-08-18 06:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 06:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-08-17 02:56:18 EDT
I've been researching the breakage of playing back mmsh streams in rawhide (with the necessary 3th party plugins installed) and I've come to the conclusion that this is caused by totem no longer passing get parameters in an URL through to gstreamer:

Using Fedora 9 with totem 2.23.2 (from Fedora 9 updates) opening the following
url works fine:
mmsh://av.rtl.nl/web/components/actueel/editienl/2008/week33/vr18.Editie_NL_15-08-2008.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf

And using gstreamer debugging I can see the full URL gets passed to mmssrc

Using the same Fedora 9 (and thus 100% identical gstreamer) with totem updated
to 2.23.4 (from rawhide) and having the rawhide evolution-data-server parallel
installed to the F-9 one for deps, opening the same URL, only the following
part gets passed to mmssrc:
mmsh://av.rtl.nl/web/components/actueel/editienl/2008/week33/vr18.Editie_NL_15-08-2008.MiMedia_WM_1500K_V9.wmv

Notice the missing: "?MSWMExt=.asf" at the end. This breaks playback of mmsh
video streams.

Note I've also reported this upstream (which I know ends up at the same person, but I wanted to make this block the F10Target tracker).
Comment 1 Hans de Goede 2008-08-17 02:56:55 EDT
Erm, forgot the upstream bug url which is:
http://bugzilla.gnome.org/show_bug.cgi?id=545864
Comment 2 Bastien Nocera 2008-08-18 06:10:57 EDT
There's no point in filing an upstream _and_ a distro bug. The person looking at the bugs is the same (ie. me).

Note You need to log in before you can comment on or make changes to this bug.