Bug 459356 - Evolution hung while waiting for keyring daemon
Evolution hung while waiting for keyring daemon
Status: CLOSED DUPLICATE of bug 528393
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-17 07:23 EDT by Gilboa Davara
Modified: 2015-03-03 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-19 07:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2008-08-17 07:23:35 EDT
Description of problem:
As the title suggests, evolution tends to hang under KDE 4.1. May or may not be related to a previously reported gnome-keyring bug.

Version-Release number of selected component (if applicable):
evolution-2.22.3.1-1.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start evolution.
2. Let it idle for a couple of hours.
  
Additional info:

Console dump:
$ evolution

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory
CalDAV Eplugin starting up ...
** (evolution:9923): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:9923): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory

** (evolution:9923): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory


gdb dump (post hang)
$ gdb /usr/bin/evolution -p 4126
[...]
(gdb) thread apply all bt

Thread 5 (Thread 0x43754950 (LWP 4134)):
#0  0x0000003afd6da9f6 in poll () from /lib64/libc.so.6
#1  0x0000003aff23ab58 in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003aff23b1ed in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3  0x0000003b09208913 in ?? () from /usr/lib64/libnm_glib.so.0          
#4  0x0000003aff260474 in ?? () from /lib64/libglib-2.0.so.0             
#5  0x0000003afe20729a in start_thread () from /lib64/libpthread.so.0    
#6  0x0000003afd6e439d in clone () from /lib64/libc.so.6                 

Thread 4 (Thread 0x42352950 (LWP 4387)):
#0  0x0000003afd6da9f6 in poll () from /lib64/libc.so.6
#1  0x0000003aff23ab58 in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003aff23b1ed in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3  0x0000003b17c1847d in ?? () from /usr/lib64/libebook-1.2.so.9        
#4  0x0000003aff260474 in ?? () from /lib64/libglib-2.0.so.0             
#5  0x0000003afe20729a in start_thread () from /lib64/libpthread.so.0    
#6  0x0000003afd6e439d in clone () from /lib64/libc.so.6                 

Thread 3 (Thread 0x404d2950 (LWP 4389)):
#0  0x0000003afd6da9f6 in poll () from /lib64/libc.so.6
#1  0x0000003aff23ab58 in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003aff23b1ed in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3  0x0000003b08a47df0 in ?? () from /usr/lib64/libORBit-2.so.0          
#4  0x0000003aff260474 in ?? () from /lib64/libglib-2.0.so.0             
#5  0x0000003afe20729a in start_thread () from /lib64/libpthread.so.0    
#6  0x0000003afd6e439d in clone () from /lib64/libc.so.6                 

Thread 2 (Thread 0x44155950 (LWP 8932)):
#0  0x0000003afe20af19 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003aff213fdc in ?? () from /lib64/libglib-2.0.so.0                           
#2  0x0000003b174161ce in e_msgport_wait () from /usr/lib64/libedataserver-1.2.so.9    
#3  0x0000003b1601d2a9 in ?? () from /usr/lib64/libedataserverui-1.2.so.8              
#4  0x0000003b1601f412 in e_passwords_get_password () from /usr/lib64/libedataserverui-1.2.so.8
#5  0x0000000001e9b226 in ?? () from /usr/lib64/evolution/2.22/components/libevolution-mail.so
#6  0x00007f4044acec4d in ?? () from /usr/lib64/evolution-data-server-1.2/camel-providers/libcamelpop3.so
#7  0x00007f4044acf636 in ?? () from /usr/lib64/evolution-data-server-1.2/camel-providers/libcamelpop3.so
#8  0x0000003b17037a01 in camel_service_connect () from /usr/lib64/libcamel-provider-1.2.so.11
#9  0x0000003b1703910f in camel_session_get_service_connected ()
   from /usr/lib64/libcamel-provider-1.2.so.11
#10 0x0000000001e9ceff in mail_tool_get_inbox ()
   from /usr/lib64/evolution/2.22/components/libevolution-mail.so
#11 0x0000000001e97e86 in ?? () from /usr/lib64/evolution/2.22/components/libevolution-mail.so
#12 0x0000000001e9377a in ?? () from /usr/lib64/evolution/2.22/components/libevolution-mail.so
#13 0x0000003aff261a07 in ?? () from /lib64/libglib-2.0.so.0
#14 0x0000003aff260474 in ?? () from /lib64/libglib-2.0.so.0
#15 0x0000003afe20729a in start_thread () from /lib64/libpthread.so.0
#16 0x0000003afd6e439d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f404d4027e0 (LWP 4126)):
#0  0x0000003afe20db8b in read () from /lib64/libpthread.so.0
#1  0x0000003b0fc04ceb in ?? () from /usr/lib64/libgnome-keyring.so.0
#2  0x0000003b0fc0739d in ?? () from /usr/lib64/libgnome-keyring.so.0
#3  0x0000003b0fc07827 in gnome_keyring_find_items_sync () from /usr/lib64/libgnome-keyring.so.0
#4  0x0000003b1601d760 in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#5  0x0000003b1601de93 in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#6  0x0000003b1601d182 in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#7  0x0000003aff2374db in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#8  0x0000003aff23acbd in ?? () from /lib64/libglib-2.0.so.0
#9  0x0000003aff23b1ed in g_main_loop_run () from /lib64/libglib-2.0.so.0
#10 0x0000003b1042d276 in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#11 0x0000000000416fa5 in ?? ()
#12 0x0000003afd61e32a in __libc_start_main () from /lib64/libc.so.6
#13 0x000000000040a379 in gtk_toggle_button_set_active ()
#14 0x00007fff55460558 in ?? ()
#15 0x000000000000001c in ?? ()
#16 0x0000000000000001 in ?? ()
#17 0x00007fff554613f8 in ?? ()
#18 0x0000000000000000 in ?? ()
(gdb)
Comment 1 Gilboa Davara 2008-08-17 07:24:44 EDT
KDM/keyring bug.

https://bugzilla.redhat.com/show_bug.cgi?id=453880

P.S. I'm still using gdm, so this may be completely unrelated.

- Gilboa
Comment 2 Matthew Barnes 2008-08-17 10:25:45 EDT
It is indeed hanging on a gnome-keyring request in that backtrace, and these warnings are telling:

** (evolution:9923): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-hEkvzf/socket: No such file or directory

Looks like maybe the keyring-daemon wasn't running.  I would hope gnome-keyring's client API would be smart enough not to hang in that situation.
Comment 3 Gilboa Davara 2008-08-17 12:05:10 EDT
As there seem to be an issue between KDE 4.x and keyring, I have killed and started gnome-keyring manually before starting evolution.

$ killall gnome-keyring-daemon 

$ gnome-keyring-daemon
** Message: another SSH agent is running at: /tmp/ssh-xANkc13395/agent.13395
GNOME_KEYRING_SOCKET=/tmp/keyring-EuOLnd/socket
SSH_AUTH_SOCK=/tmp/keyring-EuOLnd/ssh
GNOME_KEYRING_PID=23541

$ evolution

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory
CalDAV Eplugin starting up ...
** (evolution:23544): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:23544): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided byany .service files

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory

** (evolution:23544): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-8iuNAc/socket: No such file or directory
Comment 4 Gilboa Davara 2008-08-17 12:13:00 EDT
OK, I see the problem (evolution is looking for the wrong keyring)

Never the less, evolution -is- using a keyring (I get the password prompt) and works fine for hours... what gives?

- Gilboa
Comment 5 Gilboa Davara 2008-10-19 23:31:42 EDT
Evolution still hangs on a rather regular basis - every 3-5 hours.
As suggested elsewhere, I used the gnome-keyring-manager and removed all the existing keyrings - but it had a limited effect. (Evolution now hangs once every couple of hours instead of once an hour).

Is anyone looking into this bug?

- Gilboa
Comment 6 Gilboa Davara 2008-10-19 23:36:20 EDT
P.S. I wonder if this isn't a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=354041

- Gilboa
Comment 7 Mike Chambers 2009-03-07 08:41:15 EST
Do you still see this problem? Can you report what version of evolution you are using? And if you are still experiencing this problem, are you still using Fedora 9 or have you upgraded to 10 or possibly Rawhide?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Gilboa Davara 2009-03-08 08:34:38 EDT
$ rpm -q evolution
evolution-2.24.5-1.fc10.x86_64

Still seeing the same problem on multiple F10 installations.
Cannot test it on Rawhide - production machine(s).

- Gilboa
Comment 9 Milan Crha 2009-03-09 09:49:34 EDT
Could you install evolution, evolution-data-server and gtkhtml3 debuginfo packages and upload here updated backtrace of the hang, please? Thanks in advance.
Comment 10 Gilboa Davara 2009-03-10 12:01:35 EDT
(gdb) thread apply all bt            

Thread 5 (Thread 0x7f2d638d5950 (LWP 23739)):
#0  0x0000003f65adc886 in __poll (fds=0x1b062b0, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003176c3ae08 in g_main_context_poll () at gmain.c:3091                                            
#2  g_main_context_iterate (context=0x1be5780, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2773
#3  0x0000003176c3b49d in IA__g_main_loop_run (loop=0x1abb650) at gmain.c:2986                                 
#4  0x0000003db6e07e63 in ?? () from /usr/lib64/libnm_glib.so.0                                                
#5  0x0000003176c60d44 in g_thread_create_proxy (data=0x1ae7080) at gthread.c:635                              
#6  0x0000003f666073da in start_thread (arg=<value optimized out>) at pthread_create.c:297                     
#7  0x0000003f65ae62bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112                            

Thread 4 (Thread 0x7f2d6257c950 (LWP 29410)):
#0  0x0000003f65adc886 in __poll (fds=0x7f2d36ff33b0, nfds=9, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003176c3ae08 in g_main_context_poll () at gmain.c:3091                                                 
#2  g_main_context_iterate (context=0x1daad00, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2773  
#3  0x0000003176c3b49d in IA__g_main_loop_run (loop=0x7f2d5b34c0f0) at gmain.c:2986                              
#4  0x000000317c048170 in link_io_thread_fn (data=<value optimized out>) at linc.c:396                           
#5  0x0000003176c60d44 in g_thread_create_proxy (data=0x7f2d5b31a630) at gthread.c:635                           
#6  0x0000003f666073da in start_thread (arg=<value optimized out>) at pthread_create.c:297                       
#7  0x0000003f65ae62bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112                              
Current language:  auto; currently c                                                                             

Thread 3 (Thread 0x7f2d36f70950 (LWP 29420)):
#0  0x0000003f65adc886 in __poll (fds=0x7f2d3f1c4810, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003176c3ae08 in g_main_context_poll () at gmain.c:3091                                                 
#2  g_main_context_iterate (context=0x7f2d36ff6be0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2773
#3  0x0000003176c3b49d in IA__g_main_loop_run (loop=0x7f2d3f1c49e0) at gmain.c:2986                                 
#4  0x0000003eab618d8d in startup_mainloop (arg=<value optimized out>) at e-book.c:3745                             
#5  0x0000003176c60d44 in g_thread_create_proxy (data=0x7f2d36ff7140) at gthread.c:635                              
#6  0x0000003f666073da in start_thread (arg=<value optimized out>) at pthread_create.c:297                          
#7  0x0000003f65ae62bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112                                 

Thread 2 (Thread 0x7f2d2d361950 (LWP 5660)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x0000003eaae105fd in e_flag_wait (flag=0x7f2d364a64c0) at e-flag.c:120
#2  0x0000003eac620b82 in e_passwords_get_password (component_name=0x10a1426 "Mail", key=0x7f2d54116550 "pop://gilboad@pop.gmail.com:995/")
    at e-passwords.c:1429
#3  0x0000000001077b5b in get_password (session=<value optimized out>, service=0x7f2d62c8a3f0, domain=0x10a1426 "Mail",
    prompt=0x7f2d5410d960 "Please enter the POP password for <b>gilboad</b> on host <b>pop.gmail.com</b>.", item=0x7f2d644ea1fc "password",
    flags=4, ex=0x7f2d364cdb70) at mail-session.c:190
#4  0x00007f2d644e8eea in pop3_try_authenticate (service=0x7f2d62c8a3f0, reprompt=<value optimized out>, errmsg=<value optimized out>,
    ex=0x7f2d364cdb70) at camel-pop3-store.c:485
#5  0x00007f2d644e982e in pop3_connect (service=0x7f2d62c8a3f0, ex=0x7f2d364cdb70) at camel-pop3-store.c:625
---Type <return> to continue, or q <return> to quit---
#6  0x0000003eae240581 in camel_service_connect (service=0x7f2d62c8a3f0, ex=0x7f2d364cdb70) at camel-service.c:369
#7  0x0000003eae241c8f in camel_session_get_service_connected (session=<value optimized out>, url_string=<value optimized out>,
    type=<value optimized out>, ex=0x7f2d364cdb70) at camel-session.c:275
#8  0x000000000107988f in mail_tool_get_inbox (url=<value optimized out>, ex=0x7f2d364cdb70) at mail-tools.c:70
#9  0x0000000001074736 in fetch_mail_exec (m=0x7f2d364cdb50) at mail-ops.c:297
#10 0x000000000106fcea in mail_msg_proxy (msg=0x7f2d364cdb50) at mail-mt.c:520
#11 0x0000003176c622d7 in g_thread_pool_thread_proxy (data=<value optimized out>) at gthreadpool.c:265
#12 0x0000003176c60d44 in g_thread_create_proxy (data=0x7f2d35f71400) at gthread.c:635
#13 0x0000003f666073da in start_thread (arg=<value optimized out>) at pthread_create.c:297
#14 0x0000003f65ae62bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112

Thread 1 (Thread 0x7f2d6c3ef7e0 (LWP 23701)):
#0  0x0000003f6660df5b in read () from /lib64/libpthread.so.0
#1  0x000000317c804cfb in read () at /usr/include/bits/unistd.h:45
#2  read_all (fd=65, buf=0x7f2d6c42c068 "", len=4) at gnome-keyring.c:326
#3  0x000000317c8073ad in run_sync_operation (buffer=<value optimized out>, receive_buffer=0x7fff744535d0) at gnome-keyring.c:575
#4  0x000000317c807837 in gnome_keyring_find_items_sync (type=GNOME_KEYRING_ITEM_NETWORK_PASSWORD, attributes=0x7f2d6262fb60,
    found=0x7fff74453668) at gnome-keyring.c:2141
#5  0x0000003eac61e930 in ep_keyring_lookup_passwords (user=0x7f2d35fb2ba0 "gilboad", server=0x7f2d5b3a3720 "pop.gmail.com",
    protocol=0x7f2d5b38fe30 "pop", error=0x7fff744536d0) at e-passwords.c:408
#6  0x0000003eac61f184 in ep_get_password_keyring () at e-passwords.c:842
#7  ep_get_password (msg=0x7f2d54082830) at e-passwords.c:989
#8  0x0000003eac61e2a6 in ep_idle_dispatch (data=<value optimized out>) at e-passwords.c:464
#9  0x0000003176c3779b in g_main_dispatch () at gmain.c:2144
#10 IA__g_main_context_dispatch (context=0x18f37c0) at gmain.c:2697
#11 0x0000003176c3af6d in g_main_context_iterate (context=0x18f37c0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2778
#12 0x0000003176c3b49d in IA__g_main_loop_run (loop=0x1942330) at gmain.c:2986
#13 0x000000317d42d1f6 in bonobo_main () at bonobo-main.c:311
#14 0x000000000041635f in main (argc=<value optimized out>, argv=0x7fff744539f8) at main.c:690
Current language:  auto; currently asm
Comment 11 Matthew Barnes 2009-03-10 12:07:10 EDT
Looks like a non-responsive gnome-keyring-daemon.
Comment 12 Gilboa Davara 2009-03-10 13:10:51 EDT
Yep. Figured as much.

Any idea what's next?
Comment 13 Matthew Barnes 2009-03-10 16:07:59 EDT
Think whatever it is might be fixed in upstream gnome-keyring.

Reports of this sort were steady for awhile but have tapered off.
Comment 14 Matthew Barnes 2009-06-28 22:03:06 EDT
Are you still getting these hangs with Fedora 11.  I haven't seen them myself for quite awhile.
Comment 15 Gilboa Davara 2009-06-29 05:20:53 EDT
Gah.
Due to bug #508516, I'm forced to stick to F10 on all my KDE machines until the bug is resolved :(

- Gilboa
Comment 16 Gilboa Davara 2009-07-11 05:03:44 EDT
Just installed F11.
Seeing the same under KDE 4.2.

(gdb) bt
#0  0x00000031a7c0ddcb in read () from /lib64/libpthread.so.0
#1  0x00000031b7e0bdca in gnome_keyring_socket_read_all () from /usr/lib64/libgnome-keyring.so.0
#2  0x00000031b7e0be57 in gnome_keyring_socket_read_buffer () from /usr/lib64/libgnome-keyring.so.0
#3  0x00000031b7e06a22 in ?? () from /usr/lib64/libgnome-keyring.so.0
#4  0x00000031b7e06e87 in gnome_keyring_find_items_sync () from /usr/lib64/libgnome-keyring.so.0
#5  0x00007fafff783b00 in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#6  0x00007fafff7842c2 in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#7  0x00007fafff78341e in ?? () from /usr/lib64/libedataserverui-1.2.so.8
#8  0x00000031a8837afe in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#9  0x00000031a883b1d8 in ?? () from /lib64/libglib-2.0.so.0
#10 0x00000031a883b635 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#11 0x0000003d2802d026 in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#12 0x00000000004162ba in main ()
(gdb) k
Kill the program being debugged? (y or n) y

- Gilboa
Comment 17 Gilboa Davara 2009-10-17 13:08:08 EDT
Any prospects of getting this bug looked into?
Can I somehow disable keyring until this bug get fixed?

- Gilboa
Comment 18 Gilboa Davara 2009-10-17 14:06:51 EDT
P.S. Seems that killing gnome-keyring-daemon forces evolution to wakeup and restart it.

- Gilboa
Comment 19 Gilboa Davara 2009-10-17 14:08:16 EDT
Re-filling bug against gnome-keyring-daemon.

- Gilboa
Comment 20 Milan Crha 2009-10-19 07:28:21 EDT
This is most likely the same issue as bug #528393, which had been upstreamed and the upstream bug contains suggestions how to fix it. I'm marking this older bug as a duplicate to the newer, because of the slightly more progress done there.

*** This bug has been marked as a duplicate of bug 528393 ***

Note You need to log in before you can comment on or make changes to this bug.