This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 459358 - Double-clicking rpms in evolution barfs if spaces in path
Double-clicking rpms in evolution barfs if spaces in path
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-17 09:36 EDT by Ed Avis
Modified: 2008-10-26 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-26 12:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-08-17 09:36:00 EDT
Either evolution or the program that handles installing rpms when double-clicked (PackageKit?), or maybe the glue between them, cannot cope with spaces in pathnames.

How to reproduce: do a clean Fedora 9 installation.  Reboot and log in.  Put the DVD in the drive and it gets automatically mounted at /media/Fedora 9 x86_64 DVD.  (At least with the DVD I have; note the spaces in the pathname.)

Browse to the Packages directory using Evolution and double-click on an rpm package.  Enter the root password when prompted.  The Install Package window appears with an error:

Can't install /media/Fedora

Note that the pathname has been chopped at the first space character.

My guess is it's PackageKit at fault, since if you right-click and Open with Archive Manager it works fine.
Comment 1 Richard Hughes 2008-08-18 04:27:21 EDT
Should be fixed if you update PackageKit, it was a bug in the filename handling code fixed a few months ago. Please reopen if updating PackageKit doesn't fix this. Thanks.

*** This bug has been marked as a duplicate of bug 445158 ***
Comment 2 Ed Avis 2008-08-18 19:38:01 EDT
I did 'yum update' (for the first time since installing the system).  The old error is gone but now a different message is displayed:

failed to get a TID: Incorrect path with ';' returned!

This when I try to install /media/Fedora 9 x86_64 DVD/Packages/a2ps-4.13b-71.fc9.i386.rpm by double-clicking on the icon.
Comment 3 Richard Hughes 2008-10-26 12:32:18 EDT
This works for me now, with any 0.3.x version of PackageKit.

Note You need to log in before you can comment on or make changes to this bug.