Bug 459359 - BROWSE_MODE isn't a mode it is a feature
Summary: BROWSE_MODE isn't a mode it is a feature
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs
Version: 8
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Moyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-17 13:39 UTC by JW
Modified: 2008-08-26 12:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-26 12:29:37 UTC
Type: ---


Attachments (Terms of Use)

Description JW 2008-08-17 13:39:50 UTC
Description of problem:
The autofs config file has a poorly documented variable BROWSE_MODE. The inline documentation states "maps are browsable by default". Ok, so why isn't the variable named BROWSEABLE?  Because BROWSE_MODE seems to indicate a choice of modes, such as "BROWSE_MODE=mode1" or "BROWSE_MODE=mode2".  But instead it is "BROWSE_MODE=no" ... which seems to be a strange name for a mode!

Version-Release number of selected component (if applicable):
autofs-5.0.2-16

How reproducible:
Always

Steps to Reproduce:
1.  see description

Actual results:


Expected results:


Additional info:

Comment 1 Jeff Moyer 2008-08-26 12:29:37 UTC
I think you're splitting hairs.  If you want this changed, then I'd advise you to submit a patch upstream, and make sure that it maintains backwards compatibility.  The linux autofs mailing list is autofs@linux.kernel.org.

I hope this helps.

Cheers,

Jeff

Comment 2 JW 2008-08-26 12:45:07 UTC
Thanks for your expert advice. As if RedHat never split hairs!

Why is it that such a magnificent and innovative corporation like RedHat has not yet discovered a way of automatically linking their bug reports with "upstream" bug reporting facilities? Truly remarkable!

Comment 3 Jeff Moyer 2008-08-26 12:55:38 UTC
(In reply to comment #2)
> Thanks for your expert advice. As if RedHat never split hairs!

> Why is it that such a magnificent and innovative corporation like RedHat has
> not yet discovered a way of automatically linking their bug reports with
> "upstream" bug reporting facilities? Truly remarkable!

We do have the ability to link to upstream bugzilla databases.  However,
the upstream bug reporting facility for autofs is the autofs mailing list.  I have not filed the report upstream for you because I feel you would do a better job stating your position than I.

Cheers,

Jeff


Note You need to log in before you can comment on or make changes to this bug.