Bug 459364 - Crash when loading blank optical media
Crash when loading blank optical media
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-08-17 13:42 EDT by Adam Huffman
Modified: 2015-03-03 17:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 19:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2008-08-17 13:42:30 EDT
Description of problem:
On Rawhide I'm having some trouble with the loading of blank optical media.  Sometimes when a disc is loaded, I see the following in /var/log/messages:

gvfs-hal-volume[3455] general protection ip:407f50 sp:7fffb5c6acf8 error:0 in gvfs-hal-volume-monitor[400000+1d000]

This means the "blank disc" icon doesn't appear on the desktop.

These are the kernel messages when this happens:

Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Sense Key : Blank Check [current] 
Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
Aug 17 18:35:44 marcel kernel: end_request: I/O error, dev sr0, sector 0
Aug 17 18:35:44 marcel kernel: Buffer I/O error on device sr0, logical block 0
Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Sense Key : Blank Check [current] 
Aug 17 18:35:44 marcel kernel: sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
Aug 17 18:35:44 marcel kernel: end_request: I/O error, dev sr0, sector 0
Aug 17 18:35:44 marcel kernel: Buffer I/O error on device sr0, logical block 0
Aug 17 18:35:45 marcel kernel: cdrom: This disc doesn't have any tracks I recognize!

Version-Release number of selected component (if applicable):
gvfs-0.99.4-1.fc10.x86_64

How reproducible:
With some discs

Steps to Reproduce:
1. Insert a blank disc
2.
3.
  
Actual results:
Sometimes no blank disc icon appears

Expected results:
The blank disc icon should appear on the desktop

Additional info:
Comment 1 Matthias Clasen 2008-09-07 17:09:53 EDT
Are you still seeing this ? There were some refcounting fixes in gvfs recently that might be responsible for this.
Comment 2 Adam Huffman 2008-09-09 03:43:12 EDT
Happened again just now, with latest rawhide:

Sep  9 08:32:11 marcel kernel: cdrom: This disc doesn't have any tracks I recognize!
Sep  9 08:32:12 marcel kernel: gvfs-hal-volume[3594]: segfault at 18 ip 00000000004093d0 sp 00007fffc59380c0 error 4 in gvfs-ha
l-volume-monitor[400000+1d000]
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Sense Key : Blank Check [current] 
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
Sep  9 08:32:12 marcel kernel: end_request: I/O error, dev sr0, sector 0
Sep  9 08:32:12 marcel kernel: Buffer I/O error on device sr0, logical block 0
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Sense Key : Blank Check [current] 
Sep  9 08:32:12 marcel kernel: sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
Sep  9 08:32:12 marcel kernel: end_request: I/O error, dev sr0, sector 0
Sep  9 08:32:12 marcel kernel: Buffer I/O error on device sr0, logical block 0
Comment 3 Matthias Clasen 2008-10-03 23:55:38 EDT
David, this looks like a gvfs-hal-volume-manager segfault. 
Any idea ?
Comment 4 Bastien Nocera 2008-10-22 17:53:27 EDT
Could we please get a backtrace from the crash?

Something like this should get you a core dump:
ulimit -c unlimited
/usr/libexec/gvfsd -r # This replaces the currently running gvfsd
Comment 5 Adam Huffman 2008-10-22 19:29:34 EDT
Am not able to reproduce it at the moment - still see the kernel errors when a blank disc is inserted, but gvfs-hal-volume-manager doesn't crash.  Feel free to close and I'll reopen if it recurs.
Comment 6 Gunnar Thielebein 2009-03-31 15:36:43 EDT
what dvd writer is this issue about?
Comment 7 Adam Huffman 2009-04-01 03:29:01 EDT
Pioneer DVR-215D

Note You need to log in before you can comment on or make changes to this bug.