Bug 459370 - resolv.conf missing domain search
resolv.conf missing domain search
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-17 17:53 EDT by David Highley
Modified: 2008-09-28 14:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 14:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Highley 2008-08-17 17:53:28 EDT
Description of problem:
Adding SEARCH entry to /etc/sysconfig/network-scripts/ifcfg-eth0 does not work.


Version-Release number of selected component (if applicable):
1.60-84.fc8 also effects Fedora 9

How reproducible:
Reboot system.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
nameserver
nameserver

Expected results:
nameserver
nameserver
search

Additional info:
Adding the following to /etc/rc.local is a work around:
echo search highley-recommended.com >>/etc/resolv.conf
Comment 1 Zdenek Prikryl 2008-08-19 08:01:26 EDT
Could you please append your ifcfg-eth0 as an attachment? Thanks.
Comment 2 David Highley 2008-08-19 09:16:50 EDT
/etc/sysconfig/network-scripts/ifcfg-eth0 file:
# Broadcom Corporation NetXtreme BCM5703X Gigabit Ethernet
DEVICE=eth0
BOOTPROTO=static
BROADCAST=10.2.2.255
HWADDR=00:E0:81:2C:B7:BA
IPADDR=10.2.2.7
IPV6INIT=yes
IPV6_AUTOCONF=yes
NETMASK=255.255.255.0
NETWORK=10.2.2.0
GATEWAY=10.2.2.1
ONBOOT=yes
SEARCH=highley-recommended.com
DNS1=10.2.2.3
DNS2=10.2.2.2
Comment 3 Zdenek Prikryl 2008-08-19 09:43:03 EDT
Does this change help?

...
DNS1=10.2.2.3
DNS2=10.2.2.2
SEARCH="highley-recommended.com"
...
Comment 4 David Highley 2008-08-19 10:49:20 EDT
Quotation marks around the domain does not fix the issue. But I just tested changing:
From SEARCH=highley-recommended.com
To DOMAIN=highley-recommended.com

Now /etc/resolv.conf gets generated to:
# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
# DNS1=xxx.xxx.xxx.xxx
# DNS2=xxx.xxx.xxx.xxx
# SEARCH=lab.foo.com bar.foo.com
nameserver 10.2.2.3
nameserver 10.2.2.2
search highley-recommended.com

Tested by doing; service network restart.
Comment 5 Zdenek Prikryl 2008-08-20 06:24:50 EDT
I'm reassigning this to initscripts, because /etc/sysconfig/network-scripts/ifcfg-eth0 is processed by shell scripts from this package. Net-tools doesn't modify or create resolf.conf anyway.
Comment 6 Bill Nottingham 2008-08-21 00:35:32 EDT
initscripts has never used SEARCH. DOMAIN is the proper key to use.
Comment 7 David Highley 2008-08-24 21:59:27 EDT
I can't agree that this is not a bug as the /etc/resolv.conf file is getting generated with a comment to create an entry in the /etc/sysconfig/network-scripts file using the key word search. So the bug seems to be an incorrectly generated file comment which is miss leading.
Comment 8 Bill Nottingham 2008-08-25 15:09:07 EDT
Can you paste the file?
Comment 9 David Highley 2008-08-25 17:58:00 EDT
The generated /etc/resolv.conf file:
# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
# DNS1=xxx.xxx.xxx.xxx
# DNS2=xxx.xxx.xxx.xxx
# SEARCH=lab.foo.com bar.foo.com
Comment 10 Bill Nottingham 2008-08-26 11:22:07 EDT
That comment comes from NetworkManager - it needs updated to say that it should be DOMAIN=.
Comment 11 Dan Williams 2008-08-26 21:06:29 EDT
Bill: I thought we agreed on SEARCH over IRC a long time ago?  Did that get changed to DOMAIN now or something?
Comment 12 Bill Nottingham 2008-08-27 11:28:06 EDT
Hah, yes. DOMAIN is what was always used, but that's using one key for multiple things. We had agreed to add SEARCH, but that didn't get added yet (and is unlikely to be added for Fedora 8 in any case). 

Will get it added for rawhide and possibly F9 shortly.
Comment 13 Dan Williams 2008-08-27 11:39:52 EDT
Understood; how should I treat DOMAIN then?  Just like SEARCH except that it should contain only one item?  Or can DOMAIN contain more than one whitespace-separated item?

It looks like ifup-post would handle DOMAIN-with-multiple-items OK, so should we just ignore SEARCH and use DOMAIN exclusively?
Comment 14 Bill Nottingham 2008-08-27 12:25:50 EDT
From the earlier conversation, using DOMAIN will cause it to ignore and not put any 'domain ...' lines in /etc/resolv.conf, in favor of 'search ...'. If you're OK with that, we could go down that route. Are you using the DOMAIN value for anything else?
Comment 15 Dan Williams 2008-08-27 15:40:20 EDT
AFAIUI since 'domain' and 'search' are mutually exclusive in resolv.conf anyway, and NM will populate 'search' if there is more than one search sent back by the DHCP server or VPN connection.

The resolver behavior between 'domain' and 'search' is subtly different, but it looks like ifup-post will just dump everything in 'search' anway.

I'm fine with just using DOMAIN.  Lets forget we ever talked about SEARCH.
Comment 16 Dan Williams 2008-08-27 15:43:37 EDT
Fixed in upstream NM svn 4022.
Comment 17 Fedora Update System 2008-08-29 10:56:33 EDT
NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9
Comment 18 Fedora Update System 2008-09-02 16:41:45 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8
Comment 19 Fedora Update System 2008-09-10 02:36:42 EDT
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7375
Comment 20 Fedora Update System 2008-09-10 02:54:35 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openvpn NetworkManager-vpnc NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7484
Comment 21 Fedora Update System 2008-09-28 14:42:57 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2008-09-28 14:45:30 EDT
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.