Bug 459377 - sysstat tools report dual PIII as 3 CPU but /proc/cpuinfo is correct
sysstat tools report dual PIII as 3 CPU but /proc/cpuinfo is correct
Status: CLOSED DUPLICATE of bug 442801
Product: Fedora
Classification: Fedora
Component: sysstat (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-17 23:12 EDT by Roland Roberts
Modified: 2008-08-18 03:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 03:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland Roberts 2008-08-17 23:12:09 EDT
Description of problem:

sysstat tools report my dual PIII as having 3 CPUs.  CPU 2 does always show up with no activity.


Version-Release number of selected component (if applicable):

278 root> rpm -q sysstat
sysstat-7.0.4-3.fc8

How reproducible:

run mpstat -P ALL, or
sar -P ALL


Steps to Reproduce:
1. mpstat -P ALL, or
2. sar -P ALL
  
Actual results:

272 root> mpstat  -P ALL
Linux 2.6.25.14-69.fc8 (tycho.rlent.pnet)       08/17/2008

11:07:23 PM  CPU   %user   %nice    %sys %iowait    %irq   %soft  %steal   %idle    intr/s
11:07:23 PM  all    0.70   97.68    0.74    0.22    0.02    0.14    0.00    0.50     55.41
11:07:23 PM    0    0.84   97.39    0.80    0.25    0.04    0.24    0.00    0.45     52.12
11:07:23 PM    1    0.56   97.97    0.68    0.19    0.00    0.05    0.00    0.55      3.29
11:07:23 PM    2    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00      0.00

276 root> sar -P ALL 1
Linux 2.6.25.14-69.fc8 (tycho.rlent.pnet)       08/17/2008

11:08:05 PM     CPU     %user     %nice   %system   %iowait    %steal     %idle
11:08:06 PM     all      0.00     99.50      0.50      0.00      0.00      0.00
11:08:06 PM       0      0.00     99.00      1.00      0.00      0.00      0.00
11:08:06 PM       1      0.00    100.00      0.00      0.00      0.00      0.00
11:08:06 PM       2      0.00      0.00      0.00      0.00      0.00      0.00

Average:        CPU     %user     %nice   %system   %iowait    %steal     %idle
Average:        all      0.00     99.50      0.50      0.00      0.00      0.00
Average:          0      0.00     99.00      1.00      0.00      0.00      0.00
Average:          1      0.00    100.00      0.00      0.00      0.00      0.00
Average:          2      0.00      0.00      0.00      0.00      0.00      0.00

277 root> cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III CPU family      1400MHz
stepping        : 1
cpu MHz         : 1399.624
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 2801.24
clflush size    : 32

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III CPU family      1400MHz
stepping        : 1
cpu MHz         : 1399.624
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 2798.75
clflush size    : 32


Expected results:

I expect only 2 CPUs....

Additional info:

System is up-to-date FC8 just upgraded from FC5->FC6-FC7->FC8.  I've run rpm -Va and made sure sytem is consistent after the upgrade.  No package report any problems other than configuration files having changed.  All current updates were applied after the FC8 upgrade.
Comment 1 Roland Roberts 2008-08-17 23:18:25 EDT
Checking against two other hosts running Fedora 8 and the same version of sysstat, I found my dual Xeon (hyperthread enabled) report 5 CPUs from sar/mpstat (but /proc/cpuinfo is correct and shows 4).  Ditto for a Core 2 Quad system.
Comment 2 Ivana Varekova 2008-08-18 03:36:36 EDT

*** This bug has been marked as a duplicate of bug 442801 ***

Note You need to log in before you can comment on or make changes to this bug.