Bug 459384 - crond not reboot-save within DomU xen client machines
crond not reboot-save within DomU xen client machines
Status: CLOSED DUPLICATE of bug 426861
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 05:46 EDT by Florian La Roche
Modified: 2009-12-14 16:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 08:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2008-08-18 05:46:34 EDT
Description of problem:

Define a xen-server with several guest systems. If you reboot the
main xen-server Xen0, then the guest systems keep on running without
noticing the reboot. You can see this by looking at "uptime" etc.

After the reboot, the crond running in client DomU systems are
still running, but fail to run scheduled cron-scripts.

Maybe missed cron calls will completely make it fail to run
further requests?

Workaround: After a reboot of Dom0, run "service crond restart" in all
DomU systems.

regards,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2008-08-18 06:19:43 EDT
Urm, it is impossible to guests to continue running while you reboot the dom0.

Are you perhaps using the xendomains script to save running guests to disk, and then restoring them on next boot ?
Comment 2 Florian La Roche 2008-08-18 07:00:35 EDT
Right, xendomains is saving/restoring the DomU machines.

regards,

Florian La Roche
Comment 3 Chris Lalancette 2008-08-18 08:14:57 EDT
OK.  In that case, I would guess this is the same as BZ 426861, which exhibits similar symptoms.  I'm going to close this as a dup of that one for now; if it turns out that that does not fix this issue, please re-open.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 426861 ***

Note You need to log in before you can comment on or make changes to this bug.