Bug 459394 - German Umlauts are shown incorrectly
German Umlauts are shown incorrectly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 08:50 EDT by Christoph Wickert
Modified: 2008-10-02 16:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 16:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing some incorrect Umlauts (30.47 KB, image/png)
2008-08-18 08:50 EDT, Christoph Wickert
no flags Details
grip screenshort with working umlauts (52.05 KB, image/png)
2008-08-18 09:00 EDT, Adrian Reber
no flags Details

  None (edit)
Description Christoph Wickert 2008-08-18 08:50:04 EDT
Created attachment 314472 [details]
Screenshot showing some incorrect Umlauts

Description of problem:
The German translation seems to be broken and therefor Umlauts (Ä, ä, Ü, ü, Ö, ö) are shown incorrectly as you can see on the attached screenshot.

Version-Release number of selected component (if applicable):
grip-3.2.0-20.fc9.
Comment 1 Adrian Reber 2008-08-18 09:00:42 EDT
Created attachment 314473 [details]
grip screenshort with working umlauts

Interesting. If I start it with "LANG=de_DE.UTF-8  grip" all Umlauts are correctly displayed. See attached screenshot. What are your locale settings?
Comment 2 Christoph Wickert 2008-08-18 09:47:47 EDT
$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

I tried starting grip with 'LANG=de_DE.UTF8 grip' as well as LANG=de_DE.iso-8859-1: No difference.
Comment 3 Adrian Reber 2008-10-02 12:45:56 EDT
Good news everyone. I can reproduce it. Due to new hardware I have a new installation and can now confirm it.

I will try to fix it in the next few days.
Comment 4 Adrian Reber 2008-10-02 12:54:31 EDT
It is also broken for the french locale.
Comment 5 Adrian Reber 2008-10-02 16:22:53 EDT
Another try. I just requested a build for grip-3_2_0-23_fc10 which fixes the problem for me. Let me know if it is still broken. Thanks.

Note You need to log in before you can comment on or make changes to this bug.