Bug 459395 - f10a: disk encryption init script fails to stop (and prevents machine booting)
f10a: disk encryption init script fails to stop (and prevents machine booting)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 09:13 EDT by Need Real Name
Modified: 2014-03-16 23:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 17:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-08-18 09:13:15 EDT
Message at shutdown:
 Stopping disk encryption: FAILED

On reboot, I must then reboot AGAIN or my passphrase is not accepted.
Comment 1 Need Real Name 2008-08-18 09:24:42 EDT
Oh now I can't boot at all. The passphrase is always wrong (but I am typing it correctly).
Comment 2 Need Real Name 2008-08-18 10:33:56 EDT
The problem is in the halt_crypto function of
 /etc/init.d/halt

I don't know what the problem is though.

Meanwhile I have it working again after some usb stick booting and fscking.
Comment 3 Need Real Name 2008-08-18 11:28:08 EDT
fnval=1 if that helps.
Comment 4 Need Real Name 2008-08-28 17:53:00 EDT
Works now.

Note You need to log in before you can comment on or make changes to this bug.