Bug 459398 - livecdcreator triggers selinux
livecdcreator triggers selinux
Status: CLOSED DUPLICATE of bug 430075
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 09:45 EDT by Need Real Name
Modified: 2008-11-22 09:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 09:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-08-18 09:45:43 EDT
I thought livecdcreator used a chroot, not sure why this is happening:

host=box type=AVC msg=audit(1219066986.332:319): avc: denied { read } for pid=29450 comm="semanage" name="urandom" dev=loop0 ino=40964 scontext=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:device_t:s0 tclass=chr_file host=box type=SYSCALL msg=audit(1219066986.332:319): arch=40000003 syscall=5 success=yes exit=6 a0=9b4d498 a1=8000 a2=0 a3=8000 items=0 ppid=29419 pid=29450 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="semanage" exe="/usr/bin/python" subj=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 key=(null) 

host=box type=AVC msg=audit(1219066985.222:318): avc: denied { read write } for pid=29447 comm="load_policy" name="load" dev=loop0 ino=24581 scontext=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=chr_file host=box type=SYSCALL msg=audit(1219066985.222:318): arch=40000003 syscall=5 success=yes exit=4 a0=bfe39fc8 a1=8002 a2=0 a3=8002 items=0 ppid=29421 pid=29447 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="load_policy" exe="/usr/sbin/load_policy" subj=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 key=(null) 

host=box type=AVC msg=audit(1219066985.167:317): avc: denied { read } for pid=29447 comm="load_policy" name="mls" dev=loop0 ino=24580 scontext=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=file host=box type=SYSCALL msg=audit(1219066985.167:317): arch=40000003 syscall=5 success=yes exit=3 a0=bfe3b244 a1=8000 a2=0 a3=8000 items=0 ppid=29421 pid=29447 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="load_policy" exe="/usr/sbin/load_policy" subj=unconfined_u:unconfined_r:load_policy_t:s0-s0:c0.c1023 key=(null) 

host=box type=AVC msg=audit(1219066941.711:316): avc: denied { write } for pid=29404 comm="restorecon" path="/dev/null" dev=loop0 ino=40963 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:device_t:s0 tclass=chr_file host=box type=SYSCALL msg=audit(1219066941.711:316): arch=40000003 syscall=11 success=yes exit=0 a0=8543cd8 a1=8541320 a2=8541700 a3=0 items=0 ppid=29402 pid=29404 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="restorecon" exe="/sbin/setfiles" subj=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 key=(null)
Comment 1 Alan Pevec 2008-11-22 09:58:19 EST

*** This bug has been marked as a duplicate of bug 430075 ***

Note You need to log in before you can comment on or make changes to this bug.