Bug 459399 - wpa_supplicant-0.6.3-wext-handle-mac80211-mode-switches.patch clears wep keys
wpa_supplicant-0.6.3-wext-handle-mac80211-mode-switches.patch clears wep keys
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 10:13 EDT by Fabrice Bellet
Modified: 2008-11-19 09:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2008-08-18 10:13:48 EDT
The bug occurs with kernel-2.6.25.11-97.fc9.i686, using driver iwl3945. When setting adhoc-mode, the patch wpa_supplicant-0.6.3-wext-handle-mac80211-mode-switches.patch brings the interface down before setting the mode, and up just after. The problem is that this patch causes the wep keys, previously set by wpa_supplicant_set_wep_keys(), to be cleared at the driver level.

A possible workaround is to add WPA_DRIVER_FLAGS_SET_KEYS_AFTER_ASSOC to capa.flags, so the wep keys are set again a bit later after wpa_drv_associate() has been called, in function wpa_supplicant_associate(), around line 1104.

This bug causes a problem when sharing a wifi connection in ad-hoc mode with the NetworkManager, with wep enabled. The first attempt to setup the connection creates an ad-hoc network with encryption disabled (confirmed by iwlist scan from another box, and by the output of iwconfig wlan0), the second attempt to setup the same connection works, but for a reason that I could not identify, the peers that try to connect fail to obtain a dhcp lease, although the dhcp server receives queries, and correctly sends replies to these queries.
Comment 1 Dan Williams 2008-08-29 12:49:06 EDT
Ugh.  Need upstream guidance on this.
Comment 2 Fedora Update System 2008-09-02 16:47:29 EDT
wpa_supplicant-0.5.10-6.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/wpa_supplicant-0.5.10-6.fc8
Comment 3 Dan Williams 2008-09-02 16:48:19 EDT
Posted two candidate patches upstream for 0.6.x, will see what Jouni says.  Once I get some confirmation from him I'll post updates for F9 and F10.
Comment 4 Fedora Update System 2008-09-10 02:40:58 EDT
wpa_supplicant-0.5.10-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7513
Comment 5 Fedora Update System 2008-10-13 12:18:44 EDT
wpa_supplicant-0.6.4-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/wpa_supplicant-0.6.4-2.fc9
Comment 6 Fabrice Bellet 2008-10-13 12:39:52 EDT
ack, wpa_supplicant-0.6.4-2.fc9 works for me!
Comment 7 Fedora Update System 2008-10-15 22:12:41 EDT
wpa_supplicant-0.6.4-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8892
Comment 8 Fedora Update System 2008-11-19 09:48:12 EST
wpa_supplicant-0.6.4-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.