Bug 459405 - nouveau / nv drivers hang Dell with NV43GL [Quadro FX 540]
nouveau / nv drivers hang Dell with NV43GL [Quadro FX 540]
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 11:43 EDT by Daniel Qarras
Modified: 2009-03-08 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 19:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from Dell Precicion 380 (26.38 KB, text/plain)
2008-08-18 11:44 EDT, Daniel Qarras
no flags Details
lspci -vvv from Dell Precision 380 (21.72 KB, text/plain)
2008-08-18 11:45 EDT, Daniel Qarras
no flags Details
Xorg.log with nouveau driver from Dell Precision 380 before freeze (80.90 KB, text/plain)
2008-08-18 11:45 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2008-08-18 11:43:04 EDT
Description of problem (short version):
Using nouveau / nv drivers completely hang my display on daily basis while the closed nvidia driver works all ok.

Description of problem (long version):
My system is a Dell Precision WorkStation 380 which identifies its card as:

nVidia Corporation NV43GL [Quadro FX 540] rev 162

Its public Smolt profile is at:

http://www.smolts.org/client/show_all/pub_d27d5dc8-5b71-4334-9d90-6a774979d681

If I use the NVidia binary-only driver, then my machine works all ok but with nouveau / nv drivers the system hangs on daily basis. Of course I'd like to stick with the open nouveau driver but currently it is not possible. However, all this provides me the evidence that the nouveau / nv drivers are faulty, nothing else.

With nouveau the system hangs so that it answers to ping but won't let in with ssh. With nv I can still blindly enter commands but with nouveau that seems not to be the case. Also worth mentioning is that if I log into machine and kill Xorg etc the display still shows my jammed X session.

I've tried some kernel parameters like pci=nommconf but nothing seems to help. Based on Google results my card variant seems to be pretty less used, perhaps it has received less testing than other variants?

I'll attach all the log when from my system running nouveau. It also generated an oops once, it is available at:

http://www.kerneloops.org/submitresult.php?number=39343

I am using the latest BIOS available from Dell.

Lastly, I think I've been using Firefox everytime these hangs have happened and
then in dmesg I see something like:

npviewer.bin[3260]: segfault at 74646977 eip 0084b85f esp b6c615c0 error 4
npviewer.bin[3383]: segfault at 68632d6e eip 0084b85f esp b6c785a0 error 4
npviewer.bin[3476]: segfault at 67696568 eip 0084b85f esp b6c20540 error 4
npviewer.bin[3507]: segfault at 73776f72 eip 0084b85f esp 0816acb0 error 4
npviewer.bin[3566]: segfault at 73746962 eip 0084b85f esp 094f0d60 error 4
npviewer.bin[3661]: segfault at 68632d6e eip 0084b85f esp b6cc0500 error 4

PS. My hardware is 64-bit, I've tried both 32-bit and 64-bit installations, the
results are the same, the hangs happen several times a day.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 9 on a Dell Precision WorkStation 380 with latest BIOS
2. Boot the system, start using GNOME or KDE
3. See how the system hangs after few hours
  
Actual results:
System hang.

Expected results:
No hang.

Additional info:
I am willing to test any configuration options or patches that you might
suggest.

Thanks!
Comment 1 Daniel Qarras 2008-08-18 11:44:42 EDT
Created attachment 314477 [details]
dmesg output from Dell Precicion 380
Comment 2 Daniel Qarras 2008-08-18 11:45:05 EDT
Created attachment 314478 [details]
lspci -vvv from Dell Precision 380
Comment 3 Daniel Qarras 2008-08-18 11:45:27 EDT
Created attachment 314479 [details]
Xorg.log with nouveau driver from Dell Precision 380 before freeze
Comment 4 Daniel Qarras 2008-08-19 13:09:51 EDT
FWIW, somebody else too had freezes but on PPC, that bug report is at:

http://bugs.freedesktop.org/show_bug.cgi?id=15650

PS. If preferred, I could bug this to freedesktop bugzilla.
Comment 5 Andrew McNabb 2008-09-11 12:39:55 EDT
Daniel, bug 15650 is actually x86_64 (not ppc).  Also, bug 15650 is a freeze on X startup, not during normal operation, so I think it's a different bug.
Comment 6 Bug Zapper 2008-11-25 21:48:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Daniel Qarras 2008-12-14 10:05:05 EST
I have no access to this hardware any more so I can't help on this bug any way.
Comment 9 Ben Skeggs 2009-03-08 19:12:40 EDT
Closing.  Anyone experiencing the same issue and has the hw, feel free to reopen!

Note You need to log in before you can comment on or make changes to this bug.