Bug 459426 - msi wind u100: pm-suspend fails
msi wind u100: pm-suspend fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 15:12 EDT by Need Real Name
Modified: 2013-03-05 22:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 17:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pm-suspend.log (2.63 KB, text/plain)
2008-08-18 15:12 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2008-08-18 15:12:16 EDT
Created attachment 314490 [details]
pm-suspend.log

pm-hibernate works fine, but pm-suspends fails.

I don't know how to debug this, so here is the log.

I notice it seems to suspend okay, but pushing a key does nothing (probably by design).
Pushing the power button seems to do something (the hard disk light flickers a bit), but the display does nothing.
Comment 1 Need Real Name 2008-08-18 15:20:18 EDT
The box remains unpingable throughout.
Comment 2 Till Maas 2008-08-18 15:43:05 EDT
Please post the output of:

lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"

Here you can find some hints about what you can do to debug this, but I am not sure, that this may fix the problem, it could also be a kernel problem:

http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html
Comment 3 Need Real Name 2008-08-18 16:02:40 EDT
lshal output:
  system.firmware.version = '4.6.3'  (string)
  system.hardware.product = 'U-100'  (string)
  system.hardware.vendor = 'MICRO-STAR INTERNATIONAL CO., LTD'  (string)
  system.hardware.version = 'Ver.001'  (string)
Comment 4 Need Real Name 2008-08-18 16:18:32 EDT
Hm, the box is actually resumed, but the screen is still asleep, even with --quirk-dpms-on
Comment 5 Need Real Name 2008-08-18 16:22:39 EDT
--quirk-dpms-suspend too. I have no more quirks to try.
Comment 6 Need Real Name 2008-08-18 16:24:50 EDT
Aha! pm-suspend --quirk-vbe-post works!
Only downside is the screen goes white on resume :)
Comment 7 Need Real Name 2008-08-18 16:25:37 EDT
How can I make this permanent?
Comment 8 Till Maas 2008-08-18 16:32:33 EDT
You need to edit an xml file, probably:
20-video-quirk-pm-misc.fdi

And you need to send a patch upstream like it is described here:
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-report.html
Comment 9 Need Real Name 2008-08-18 16:44:26 EDT
Okay. For info, two quirks are needed:
 pm-suspend --quirk-vbe-post --quirk-dpms-on
The white screen problem goes away.

I can't install gcc on this box at the moment, so can't send upstream.
Comment 10 Till Maas 2008-08-18 18:53:53 EDT
I sent a patch upstream. I hope it appears in the archives soon:
http://lists.freedesktop.org/archives/hal/2008-August/thread.html

Setting to ASSIGNED because triaging is done.
Comment 11 Need Real Name 2008-08-23 11:34:35 EDT
Thanks. btw will the "MSI" prefix expand to the whole string?
Comment 12 Till Maas 2008-08-23 13:59:19 EDT
(In reply to comment #11)
> Thanks. btw will the "MSI" prefix expand to the whole string?

No, it will not. But it is not used. system.hardware.vendor is matched with the case insensitive prefix "micro-star".
Comment 13 Need Real Name 2008-08-24 15:04:47 EDT
There is a second part to this bug (but I will open a new bug if you want):

pm-suspend only works once. On the second _resume_, I just get a blank screen.

This is also noted here:
 http://forums.msiwind.net/default-msiwind/ubuntu-can-suspend-more-than-once-t854.html
Comment 14 Till Maas 2008-08-29 16:24:18 EDT
(In reply to comment #13)
> There is a second part to this bug (but I will open a new bug if you want):
> 
> pm-suspend only works once. On the second _resume_, I just get a blank screen.

If you cannot fix it with any of the know quirks, it is probably a bug in the kernel and therefore you should create a new bug with the component "kernel" to make sure the kernel guys notice this bug.
Comment 15 Till Maas 2008-10-30 05:02:38 EDT
If you are running a 2.6.27 kernel and the i915, it should probably work without any quirks. You can test it then with:

echo mem > /sys/power/state

Please report back once you have tested this, please report back.
Comment 16 Need Real Name 2008-10-30 18:14:02 EDT
2.6.27.4-47.rc3.fc10.i686

No it doesn't work. It seems to come back, but the screen stays dark.
I suspect it comes back because ctrl+alt+delete works and the disk does something.

2.6.27.4-58.fc10.i686 doesn't boot at all (switchroot failed: no such file or directory, booting has failed). So can't test that.
Comment 17 Need Real Name 2008-10-30 18:17:26 EDT
Bug 469267 entered for the second issue.
Comment 18 Bug Zapper 2008-11-25 21:48:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Need Real Name 2008-12-07 08:44:13 EST
(In reply to comment #15)
> If you are running a 2.6.27 kernel and the i915, it should probably work
> without any quirks. You can test it then with:
> 
> echo mem > /sys/power/state
> 
> Please report back once you have tested this, please report back.

Works perfectly in F10.
Comment 20 Hans de Goede 2009-05-07 17:01:59 EDT
Closing per comment #19

Note You need to log in before you can comment on or make changes to this bug.