Bug 459430 - anaconda does not write ks disk encryption options to anaconda-ks.cfg
anaconda does not write ks disk encryption options to anaconda-ks.cfg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
wes hayutin
https://fedoraproject.org/wiki/QA/Tes...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 15:45 EDT by wes hayutin
Modified: 2008-08-19 13:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 13:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-08-18 15:45:01 EDT
Description of problem:

Recreate:
--install was done as a virt-guest--
Install Fedora 9 using disk encryption.
Default lvm disk partition used. 
System gets encrypted successfully.

Looking at anaconda-ks.cfg after install

--snip
authconfig --enableshadow --passalgo=sha512
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --driveorder=xvda --append="console=hvc0 rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux --drives=xvda
#part /boot --fstype ext3 --size=200 --ondisk=xvda
#part pv.2 --size=0 --grow --ondisk=xvda
#volgroup VolGroup00 --pesize=32768 pv.2
#logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=512 --grow --maxsize=1024
#logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow

%packages
@editors
@legacy-fonts
@fonts

--end snip--


according to the docs, you should see a line like
autopart --encrypted --passphrase=<password>
Comment 1 David Lehman 2008-08-18 16:06:15 EDT
This should be fixed in recent rawhide as well as the F10 Alpha. Can you verify that it is fixed in these newer releases?
Comment 2 wes hayutin 2008-08-18 20:39:39 EDT
I tried f10 Alpha, it failed to boot after putting in the encryption passwd.
I ran the test as a virt guest of rhel 5.2.  I'll get some more details tomorrow.
Comment 3 wes hayutin 2008-08-19 08:49:09 EDT
ok.. testing f10 alpha on a physical box.. w/ disk encryption.

partition layout, cleared all lvm's
/boot  200m 
/swap 512m
/         remaining drive , encrypted

fails to boot

error = 
Mount failed for selinux on /selinux: No such file or directory
switchroot:  mount failed: No such file or directory
Comment 4 David Lehman 2008-08-19 12:06:29 EDT
Yes, there are some problems with plymouth that prevent the system from booting. Apparently I forgot about them when recommending that you try the Alpha.

I have verified that this is indeed broken in the Alpha and am in the process of verifying a fix that will be included in the F10 Beta.
Comment 5 David Lehman 2008-08-19 13:05:31 EDT
Fix will be in anaconda-11.4.1.29-1.

Note You need to log in before you can comment on or make changes to this bug.