Bug 459451 - Changes in glyph point settings window could not be applied.
Changes in glyph point settings window could not be applied.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 458592
  Show dependency treegraph
 
Reported: 2008-08-18 21:32 EDT by Caius Chance
Modified: 2008-12-16 18:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 18:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from George Williams (2.16 KB, patch)
2008-08-21 00:57 EDT, Caius Chance
no flags Details | Diff

  None (edit)
Description Caius Chance 2008-08-18 21:32:26 EDT
Description of problem:
There is a problem when changing setting through glyph point settings window. All the changes are not applied.

Version-Release number of selected component (if applicable):
fontforge-20080429-1

How reproducible:
Always

Steps to Reproduce:
1. Open Liberation Fonts 1.04 file LiberationSans-Regular.sfd with fontforge.
2. Double click on 'y' (U+0079) glyph to open edit window.
3. Right click filled dots in the centre junction of strokes and select Get Info.
4. On Location tab, change Normal to Interpolated.
5. Click OK button.
  
Actual results:
The glyph point is still filled dot which means still Normal.

Expected results:
The glyph point is changed to hollow dot which means interpolated.


Additional info:
Liberation Fonts 1.04 is available at: https://fedorahosted.org/liberation-fonts/export/b2fa06aa4d23caecaac324e6e09317a4bbdf82f0/tags/liberation-fonts-1.04/src/LiberationSans-Regular.sfd
Comment 1 Caius Chance 2008-08-18 21:57:46 EDT
Reported bug to upstream mailing lists.
Comment 2 Caius Chance 2008-08-21 00:57:02 EDT
Created attachment 314682 [details]
Patch from George Williams

George Williams (gww AT silcom DOT com) is one of contributors in fontforge-devel mailing lists.
Comment 3 Kevin Fenzi 2008-08-22 19:54:07 EDT
excellent. :) 

Whats the impact here? Should we apply this patch now? Or wait for a new upstream release? 

Thoughts?
Comment 4 Caius Chance 2008-08-25 01:13:21 EDT
Hi Kevin,

I have just tested this patch when I patched on bug #458592 and this patch resolves the problem. I support the application of this patch.

Unsure if his patch is accepted to be included in next upstream release yet.

Cheers, Caio.
Comment 6 Kevin Fenzi 2008-09-03 16:18:40 EDT
Happily, this patch seems to be already applied in the latest upstream version which I have just built in rawhide. ;) 

Did you need this update in f9 as well? We try and not update fontforge in stable releases because fonts might also then need updating, leading to a lot of churn and problem. ;(
Comment 7 Caius Chance 2008-09-04 21:11:13 EDT
IMHO, since F10 is due very soon, you don't need to update in f9. :)
Comment 8 Tony Fu 2008-09-09 23:12:46 EDT
requested by Jens Petersen (#27995)
Comment 9 Kevin Fenzi 2008-12-02 01:36:05 EST
Can you confirm that this is now fixed in f10?
Comment 10 Kevin Fenzi 2008-12-16 18:18:59 EST
This seems already applied upstream, I am gonna go ahead and close this now. 

If you spot any problems with it, feel free to reopen or file a new bug.

Note You need to log in before you can comment on or make changes to this bug.