Bug 459454 - Fedora is broke. Again.
Fedora is broke. Again.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 22:55 EDT by Joseph A. Farmer
Modified: 2008-08-18 23:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 23:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph A. Farmer 2008-08-18 22:55:43 EDT
Description of problem: Can't log in.


Version-Release number of selected component (if applicable): Fedora 9


How reproducible:  Fails to login every time.


Steps to Reproduce:
1.  Try to log in.
2.  Fail.
3.
  
Actual results:  Can't log in.


Expected results:  Should be able to log in.


Additional info:  You pooched the computer again.

Frankly this is getting stupid.  I'm a tad frustrated.  This is going to be long as this is just a mess.

Gthumb used to actually work for my camera.  Plug the camera in and it would pop up and do what I needed.  No fuss, no muss.  That is worked was obviously causing pain to people as Fedora 9 decided to switch to that half-baked Nautilus GVFS nonsense.  When plugging the camera in, instead of gthumb popping up, it knew how to deal with the camera, Nautilus now grabs it instead.  Then, like a retarded puppy, it can't deal with it.  I've been updating Fedora hoping that bug would get fixed.  We know Alex pushed that GVFS gunk in at the last minute and then went on vacation.  Gthumb worked.  Why does Nautilus need to do that instead when it's too stupid?

After running a yum update today, in hopes that the bug would be fixed, the computer simply wouldn't start any more.  Lovely.  Turn the machine on and it gets to a screen with "GRUB" and that's it.  Machine is a bog standard Dell Dimension 5150.  What was updated that turned it into a brick isn't clear.

First attempt to get it functional:  boot the DVD in rescue mode and downgrade the kernel.  No dice.  Tried about 3 times.

Second attempt to get it functional:  wipe out the /etc, /lib/whatever/rpm directories.  Install Fedora to the machine.  It booted fine.  Gets to the login screen and my password doesn't work.

Rinse and repeat.

You know what I think?  I think a library changed.  I wiped out the passwd file so that should have gotten past it.  No dice.

So now the machine is in an unbootable state.  Installing Fedora over the existing drive results in the password I enter during install not working.  This is consistent: tried it 3 times.  Yes, that's 3 full installs.  Am I mistyping the password?  No.  I can CTRL-ALT-F2 to a text login screen and type the password in the username block to see it in plain text.  I am not mistyping it.

What I haven't gone into is the hours this has taken.  Multiple reboots?  EXT3 wants to check the hard drives.  That's another hour.  SELinux wants to touch all the files.  Anaconda insists on installing fonts I'd never use in a million years.  Gujarti and Korean?  Who, with an English locale, uses both of those too?  Palm pilot gunk.  Does anyone even own one any more?

8 hours.  Just because I was dumb enough to run "yum update."

Next step:  Move all of my files off of the hard drive.  Format the hard drive.  Now if everybody kept all of their files in one nice place that wouldn't be so bad.  I have fonts, I have a scanner (requires a SANE setup), I have NFS settings, etc.,  What bits I'll lose is anyone's guess.

This is getting stupid.  You are upgrading Fedora so quickly you never ship a product that works.  It's now the choice between Fedora (broken) and RHEL (ancient).

Check my bugzilla entries.  Every time I upgrade something breaks.  The change from IDE (that Polish gent) to the new SATA library (Garzik/Cox) actually ate some hard disks.  Not to mention the CD and DVD ROM problems.  Remember those?  I actually lost hard drives.

Fedora is just broken.

Was this a rant?  Yes.  Why?  Maybe if enough people tell you that you're moving too fast and never shipping a functional product, maybe you'll get the word.  I doubt it.

Ask yourselves, given that Fedora is just "RHEL Beta that never works," why would anyone have confidence in RHEL?  Fedora is just showing people that RedHat can't create a functional stable OS.  Sad really as you employ the talent.  The desire to have Fedora be perpetual BETA is just giving Red Hat a bad name.

Yes I'm frustrated.  I'm going to have to completely reload that computer.  Know what I'm going to reload it with?  Fedora 8.  Then Nautilus won't mess with the camera.  I'm going to load it with Fedora 8 and never do any updates.  At all.  An out of date OS is way better than a broken one.

Color me dropped from your beta program, code name Fedora.
Comment 1 Dave Jones 2008-08-18 23:12:08 EDT
in which case, I guess you won't be interested in attempting to debug any of your problems, so we might as well just close this.

Note You need to log in before you can comment on or make changes to this bug.