Bug 459472 - supend and hibernate non-functional on Thinkpad R61
supend and hibernate non-functional on Thinkpad R61
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 04:01 EDT by Pierre Ossman
Modified: 2010-06-28 06:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 06:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2008-08-19 04:01:54 EDT
Neither suspend nor hibernate works on my Thinkpad R61. I don't think it has ever worked, but I haven't properly mapped the failure until now.

pm-suspend causes the machine to suspend properly, but resume locks up during resume. The disk gets spun up, but the keyboard and screen are both dead and the machine does not respond to the power button.

I've tried all the quirk parameters for pm-suspend, but the result is always the same. I've also tried unloading the kvm modules.

pm-hibernate works as it should from console, but using X11 causes it to lock up after half a second. The X server is able to make some screen updates before it hangs, but then it locks up completely and doesn't respond to either keyboard nor mouse. The power button still works so it seems that it is just X that is dead.
Comment 1 Bug Zapper 2008-11-25 21:49:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Pierre Ossman 2009-03-07 13:53:14 EST
Still broken.
Comment 3 the.hw.group 2009-05-18 16:28:15 EDT
Description of problem:
Suspend and hibernate does not work on Fedora Rawhide (11) on an IBM (Lenovo) Thinkpad T60 (32bit, Centrino Duo processor). When you under the system menu (or by hitting Fn + F4) select "Shutdown..." then select suspend / hibernate, the system WILL suspend or hibernate (when selected), however the system will not fully recover from the suspend / hibernate session. When the screen comes back online, it is distorted and unreadable. I am forced ot hold down the power button on the T60, which will "hard reset" the system.

This behaviour can be reproduced on a fully updated system, (via F11 / rawhide repo) or using a stock install of fedora 11 beta, or RC, on an IBM Lenovo Thinkpad T60 with a Intel Centrino Duo processor.

Please let me know what information is needed to resolve this. Thank you!
Comment 4 Bug Zapper 2009-06-09 05:40:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Pierre Ossman 2009-09-28 12:19:43 EDT
Failure mode has changed slightly. I now get this in dmesg:

pci_legacy_suspend(): nouveau_pci_suspend+0x0/0x37 [nouveau] returns -19
pm_op(): pci_pm_freeze+0x0/0xc2 returns -19
PM: Device 0000:01:00.0 failed to freeze: error -19

or:

pci_legacy_suspend(): nouveau_pci_suspend+0x0/0x37 [nouveau] returns -19
pm_op(): pci_pm_suspend+0x0/0x12c returns -19
PM: Device 0000:01:00.0 failed to suspend: error -19
PM: Some devices failed to suspend

Depending on if I try to suspend or hibernate.

I am running KMS, which I understand is a requirement for any reasonable chance of working suspend with nouveau.
Comment 6 Pierre Ossman 2009-10-30 04:48:28 EDT
With Fedora 12, things have improved. Both suspend and hibernate work intermittently (there is a nouveau bug, but I've filed that as bug 532000), but I cannot trigger hibernate from my desktop (I have to su and call pm-hibernate directly).

Most of the time it doesn't do a damn thing except activate the screen saver when I choose "hibernate" in Gnome. Sometimes it pops up an error saying that the operation failed. I haven't found any log that say what went wrong though so it's not really that easy to debug this.
Comment 7 Bug Zapper 2010-04-27 08:12:02 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2010-06-28 06:43:05 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.