Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 459480 - Unable to print booklets (Canon iR 3170 Ci)
Summary: Unable to print booklets (Canon iR 3170 Ci)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-19 09:20 UTC by Petr Šplíchal
Modified: 2016-06-01 01:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-15 11:39:27 UTC
Type: ---


Attachments (Terms of Use)
PPD file used for setting up the printer (203.20 KB, application/octet-stream)
2008-08-19 09:20 UTC, Petr Šplíchal
no flags Details
test booklet document - A4 paper size (13.17 KB, application/pdf)
2008-08-19 09:30 UTC, Petr Šplíchal
no flags Details
test booklet document - A5 paper size (13.21 KB, application/pdf)
2008-08-19 09:31 UTC, Petr Šplíchal
no flags Details
Attaching the output of troubleshooter. (6.66 KB, text/plain)
2008-08-19 11:41 UTC, Petr Šplíchal
no flags Details
/etc/cups/ppd/canon.ppd (203.20 KB, application/octet-stream)
2008-08-19 13:42 UTC, Petr Šplíchal
no flags Details

Description Petr Šplíchal 2008-08-19 09:20:36 UTC
Created attachment 314519 [details]
PPD file used for setting up the printer

Description of problem:

I cannot use one the great features of our Canon iR 3170 Ci printer: to print booklets. After installing the printer (with attached PPD file), there are advanced options available in the print dialogue, however any time I try to print a document as a booklet I finish with the following error: Please insert A3 paper. Evidently, the pages are not shrunk to fit the default page size (which is A4), and which is (I believe) expected.

I experienced this problem both when printing from evince and openoffice, neither was I successful with okular. Before upgrading to Fedora 9 I managed to get the expected result with kpdf by setting/pretending the page size to be A5 in kpdf print dialogue (which worked also for A4 documents).

The very only constellation which works for me in Fedora 9 is creating a pure A5-paper-size document in openoffice and then printing it. After converting this document into a pdf (still A5), had no success to print it from evince. Got again the same A3-error message.

I'm not sure if this is problem of cups, but I can't find any other component which could be responsible for this issue.

Version-Release number of selected component (if applicable):
cups-1.3.7-8.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. install Canon iR 3170 Ci printer with attached PPD file
2. open/create a document in evince/openoffice 
3. in print dialogue select "Booklet Printing: On, Saddle Stitch: On"
4. print
  
Actual results:
Printer error: Please insert an A3 paper.

Expected results:
Document pages (of any size?) to be shrunk to A5 and nicely placed on the A4, four per paper, two per one side to produce fold-able booklet.

Additional info:
If you need any testing don't hesitate to contact me.
Thanx for looking into this! :-)

Comment 1 Petr Šplíchal 2008-08-19 09:30:38 UTC
Created attachment 314523 [details]
test booklet document - A4 paper size

Comment 2 Petr Šplíchal 2008-08-19 09:31:17 UTC
Created attachment 314524 [details]
test booklet document - A5 paper size

Comment 3 Tim Waugh 2008-08-19 10:54:01 UTC
Please try using the printing troubleshooter: System->Administration->Printing from the main menu, then select Help->Troubleshoot.

It will ask you to print a test page -- do so using evince with the A4 test booklet document.

Please attach the resulting troubleshoot.txt file to this bug report using the 'Add an attachment' link further up this page.

Comment 4 Petr Šplíchal 2008-08-19 11:41:58 UTC
Created attachment 314533 [details]
Attaching the output of troubleshooter.

Comment 5 Tim Waugh 2008-08-19 12:19:44 UTC
Thanks.  Now try submitting the print job using lp, like this:

lp -dcanon -oBooklet=Left -oSaddleStitch=On A4-booklet.pdf

Does that behave in the same way?

Comment 6 Petr Šplíchal 2008-08-19 13:01:57 UTC
> Thanks.  Now try submitting the print job using lp

Tim, thank YOU for your swiftness! :-)
I ran the command and the result is the same:
Load the paper bellow: A3 plain

Comment 7 Tim Waugh 2008-08-19 13:18:04 UTC
Please attach the file /etc/cups/ppd/canon.ppd (it may be slightly different than the PPD you originally used to create the queue).

Comment 8 Petr Šplíchal 2008-08-19 13:42:20 UTC
Created attachment 314538 [details]
/etc/cups/ppd/canon.ppd

There are just some DefaultOption changes:

diff /etc/cups/ppd/canon.ppd /mnt/archive/tisk/cnr317ce1.ppd
36c36
< *DefaultOption3: True
---
> *DefaultOption3: False
49c49
< *DefaultOption5: Q2OOT
---
> *DefaultOption5: None
62c62
< *DefaultOption6: True
---
> *DefaultOption6: False

Comment 9 Petr Šplíchal 2008-10-21 14:45:32 UTC
Managed to print the booklet with following steps:

1) open pdf file (A4 paper size)
2) file -> page setup -> paper size -> A5
3) file -> finishing booklet = on -> print

I'm not sure whether this is a workaround or rather expected way of how this should work. So the question now is: Shall the booklet printing behaviour with default settings be:

a) to create a booklet on the matching size of paper as the original is?
b) or to request a paper of double size of the original doc?

I'd vote for the first one, because this is what you usually do --- get docs in A4 paper size and want to print it on A4 paper size as a booklet (the same applies for letter/letter). I suppose few people would want to create booklets of A3 size as most of printers use standard local paper size of A4/letter.

Comment 10 Tim Waugh 2009-05-15 11:39:27 UTC
I think that behaviour depends on the printer's implementation.


Note You need to log in before you can comment on or make changes to this bug.