Bug 459492 - Timeouts in wait_drive_not_busy with TEAC DV-W28ECW and similar
Timeouts in wait_drive_not_busy with TEAC DV-W28ECW and similar
Status: CLOSED DUPLICATE of bug 464039
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks: 483701
  Show dependency treegraph
 
Reported: 2008-08-19 08:49 EDT by Bryn M. Reeves
Modified: 2009-02-27 04:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 04:56:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2008-08-19 08:49:08 EDT
+++ This bug was initially created as a clone of Bug #456078 +++

Description of problem:

Some TEAC drives take a long time to return to non-Busy status following an
IDENTIFY command (>=6ms), causing following messages to be logged:

08:20:36 hex kernel: hda: irq timeout: status=0xd0 { Busy }
08:20:36 hex kernel: hda: irq timeout: error=0x00
08:20:36 hex kernel: hda: ATAPI reset complete
08:20:36 hex kernel: VFS: busy inodes on changed media 

Version-Release number of selected component (if applicable):


How reproducible:
Infrequently but depends on drive/usage. Some users report the drives to be
unusable while others see only infrequent failures.

Steps to Reproduce:
1. cat /proc/ide/<drive>/identify
  
Actual results:
22 failures in 60,000 accesses:

 kernel: hda: task_in_intr: status=0xd0 { Busy }
 kernel: hda: task_in_intr: error=0xd0LastFailedSense 0x0d

Expected results:
No error logged. Drive usable as normal.

Additional info:
Reported upstream as kernel bug 10887:
http://bugzilla.kernel.org/show_bug.cgi?id=10887

And fixed in commit f54feafa6d47d0aa1a96adefdc763b708b02f94f:

Author: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date:   Fri Jun 20 20:53:33 2008 +0200

    ide: increase timeout in wait_drive_not_busy()
    
    Some ATAPI devices take longer than the current max timeout value to
    become ready (i.e. TEAC DV-W28ECW takes 6 ms) so increase the timeout
    value to 10 ms.
    
    This fixes kernel.org bugzilla bug #10887:
    http://bugzilla.kernel.org/show_bug.cgi?id=10887
    
    Reported-by: Masanari Iida <standby24x7@gmail.com>
    Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

--- Additional comment from bmr@redhat.com on 2008-07-21 08:37:20 EDT ---

Created an attachment (id=312253)
Patch increasing timeout in wait_drive_not_busy


--- Additional comment from bmr@redhat.com on 2008-07-21 08:37:59 EDT ---

This is also anecdotaly affecting drives from other vendors.


--- Additional comment from bmr@redhat.com on 2008-07-21 08:38:49 EDT ---

Related to bug 453808 for the same drive model:

qc timeout probing TEAC DV-28E-V CD/DVD drive on SATA/PATA bridge

--- Additional comment from alan@redhat.com on 2008-07-23 15:44:40 EDT ---

I'm happy with that proposed patch
Comment 1 RHEL Product and Program Management 2009-02-16 10:26:15 EST
Updating PM score.
Comment 2 Michal Schmidt 2009-02-27 04:56:23 EST

*** This bug has been marked as a duplicate of bug 464039 ***

Note You need to log in before you can comment on or make changes to this bug.