Bug 459497 - not possible to have more than 31999 directories under /var/lib/mysql
not possible to have more than 31999 directories under /var/lib/mysql
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 09:39 EDT by Zoltan Arpadffy
Modified: 2013-07-02 23:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 23:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Arpadffy 2008-08-19 09:39:42 EDT
Description of problem:
If the /var/lib/mysql directory contain more than 31999 files/directories/databases that new database creation is not possible.
This is not possible even for root.

Version-Release number of selected component (if applicable):

mysql-5.0.51a-1.fc9.i386
mysql-devel-5.0.51a-1.fc9.i386
mysqlclient10-3.23.58-9.2.1.i386
mysql-libs-5.0.51a-1.fc9.i386
mysql-server-5.0.51a-1.fc9.i386
mod_auth_mysql-3.0.0-6.i386

How reproducible:
Always.

Steps to Reproduce:
1. have more than 31999 databases
2. try to create new database 
  
Actual results:
The mysql server crashes

Expected results:
The database is created

Additional info:
This is important for web hotels, ISP etc.
fedora.polarhome.com has more than 70k accounts and more than 50k mysql databases created (usually one user one database)
Unfortunately, it is needed to be removed not used databases (subdirectories) under /var/lib/mysql in order to create new databases.

When the number of entries in /var/lib/mysql fall below 31999, the new database creation is possible.
Comment 1 Tom Lane 2008-08-21 23:36:56 EDT
This sounds like it's due to the ext3 limit on number of subdirectories in a directory.  Use another filesystem, or rethink whether you really need so many databases.

Note You need to log in before you can comment on or make changes to this bug.