This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 459509 - openldap 2.4 init script fails due to non-existent slurpd
openldap 2.4 init script fails due to non-existent slurpd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 11:40 EDT by Jeff Sheltren
Modified: 2008-08-20 10:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-20 10:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix for init script (1.48 KB, patch)
2008-08-19 11:41 EDT, Jeff Sheltren
no flags Details | Diff

  None (edit)
Description Jeff Sheltren 2008-08-19 11:40:22 EDT
Description of problem:
service ldap start fails and does not output any error.

Version-Release number of selected component (if applicable):
openldap-2.4.11-1.fc10

How reproducible:
From a clean install, run 'service ldap start'

Steps to Reproduce:
1. Install openldap-servers
2. service ldap start
  
Actual results:
No error output, but init script fails due to missing slurpd binary.


Expected results:
slapd should be started

Additional info:
slurpd has been deprecated in openldap 2.4 and is no longer included.  See
http://www.openldap.org/doc/admin24/replication.html#Replacing%20Slurpd

Attached is a patch against ldap.init to remove slurpd references and checks
Comment 1 Jeff Sheltren 2008-08-19 11:41:35 EDT
Created attachment 314552 [details]
Proposed fix for init script

Trying attachment again...
Comment 2 Jan Safranek 2008-08-20 04:30:52 EDT
Where did you get the /etc/init.d/ldap script from? I just checked that openldap-servers-2.4.11-1.fc10 (i.e. latest in rawhide) comes with init script which does not contain any 'slurpd'.

It seems to me there is something wrong in your system. It's possible that RPM did not replace old initscript with new one, could you please check it?

Please run 'rpm -q openldap-servers' and 'rpm -V openldap-servers' and review results.
Comment 3 Jeff Sheltren 2008-08-20 10:09:55 EDT
Hi Jan, you're absolutely right.  Somehow I switched the ldap init script with an older one.  Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.