Bug 459546 - cpu 50%hi because of ehci_hcd
cpu 50%hi because of ehci_hcd
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 17:38 EDT by Tobias Oed
Modified: 2008-09-10 03:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 08:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output (6.90 KB, application/octet-stream)
2008-08-22 08:19 EDT, Tobias Oed
no flags Details

  None (edit)
Description Tobias Oed 2008-08-19 17:38:33 EDT
Description of problem:
My cpus are constantly at full speed because the system is servicing hardware interupts 50% of the time. modprobe -r ehci_hcd gets rid of that load

Version-Release number of selected component (if applicable):
All f9 kernels I tried

How reproducible:
100%

Steps to Reproduce:
1. run top, watch hi at ~ 50%
top - 23:37:09 up 23:05,  4 users,  load average: 0.15, 0.11, 0.15
Tasks: 156 total,   3 running, 153 sleeping,   0 stopped,   0 zombie
Cpu(s):  1.5%us,  0.7%sy,  0.0%ni, 47.7%id,  0.2%wa, 50.0%hi,  0.0%si,  0.0%st
Mem:    903804k total,   888676k used,    15128k free,    23544k buffers
Swap:  2047476k total,      128k used,  2047348k free,   482308k cached

2. modprobe -r ehci_hcd
3. watch hi go down to 0%
top - 23:37:37 up 23:06,  4 users,  load average: 0.21, 0.13, 0.15
Tasks: 156 total,   1 running, 155 sleeping,   0 stopped,   0 zombie
Cpu(s):  5.8%us,  2.0%sy,  0.0%ni, 92.1%id,  0.2%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    903804k total,   887692k used,    16112k free,    23480k buffers
Swap:  2047476k total,      128k used,  2047348k free,   480916k cached
  
Actual results:
The system is running at full speed spending a lot of time servicing ehci_hcd interrupts

Expected results:
ehci_hcd works

Additional info:
I need noapic to boot and irqpoll if I want to use usb devices.

root@tobslap:/proc# lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation MCP51 PCI-X GeForce Go 6100 (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)
Comment 1 Chuck Ebbert 2008-08-21 21:24:05 EDT
Can you post the output of the dmidecode command as an attachment?

Also, try adding:

   io_delay=0xed

to the boot options instead of 'noapic irqpoll'.
Comment 2 Tobias Oed 2008-08-22 08:19:31 EDT
Created attachment 314793 [details]
dmidecode output
Comment 3 Tobias Oed 2008-08-22 08:23:58 EDT
[sorry if this is a dupe but bugzilla bugged when I tried to attach the file]

> Can you post the output of the dmidecode command as an attachment?

sure, it's attached

> Also, try adding:
>
>   io_delay=0xed
>
>to the boot options instead of 'noapic irqpoll'.

YES. That fixed it: no pre hi and working usb2 and apic!
I also managed to suspend/resume to ram (haven't tried it in while so may be unrelated). Hibernation freezes on resume after reading 100% from swap and printing suspending console(s).
Thanks again!
Tobias
Comment 4 Fedora Update System 2008-08-31 11:02:14 EDT
kernel-2.6.26.3-27.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-27.fc9
Comment 5 Tobias Oed 2008-08-31 17:02:13 EDT
Hello,
I'm running 2.6.26.3-27.fc9 and things appear to be running as with the standard 2.6.25.x fedora kernel but I don't need io_delay any more. Just like with that kernel, my fans are spinning constantly at low speed though. As I'm typing this I notice that the keyboard feels warmer than usual too...
Cheers
Tobias
Comment 6 Fedora Update System 2008-09-03 12:49:40 EDT
kernel-2.6.26.3-29.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-29.fc9
Comment 7 Fedora Update System 2008-09-05 08:19:43 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-09-10 03:07:07 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.