Bug 459573 - After doing a yum update, wireless will not authenticate using WPA personal.
After doing a yum update, wireless will not authenticate using WPA personal.
Status: CLOSED DUPLICATE of bug 451422
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 06:11 EDT by Mike
Modified: 2008-08-20 15:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-20 09:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It is a text file with some of my computer configs. (1.77 KB, application/octet-stream)
2008-08-20 06:11 EDT, Mike
no flags Details

  None (edit)
Description Mike 2008-08-20 06:11:40 EDT
Created attachment 314619 [details]
It is a text file with some of my computer configs.

Description of problem:I installed a new Linksys wireless card. It has a Raylink chipset rt2500. It worked out of the box with a fresh install of Fedora 9. After a yum update the wireless failed to work. Acutally the card works I can see the network but it will not join my wireless network. It fails to authenticate.

When I reboot to the old kernel the wireless works fine. There is something with the new kernel that will not let it authenticate. If that makes any sense. I have attached some specs. I will give you what ever you need to figure this out.


Version-Release number of selected component (if applicable):
uname -r original kernel:2.6.25-14.fc9.i686 <-- wireless works
uname -r new kernel : 2.6.25.14-108.fc9.i686  <-- wireless doesn't work


How reproducible:If I boot to the new kernel joining my wireless network it hangs for a while then it fails and a pop up shows some weird passphrase in the wpa window. 

If I boot to the old kernel wireless works and authenticates fine


Steps to Reproduce:
1.Log into new default kernel 
2.
3.
  
Actual results: No authentication on my wireless 


Expected results:Should just find my wireless ssid and log in with no issues. 


Additional info:Please let me know if you need any more information or if something is not clear.
Comment 1 Dan Williams 2008-08-20 08:38:53 EDT
Best thing to do here is likely to try a supplicant config with the new kernel.  I can try to help lead you through that if you like.  Do you use IRC at all?
Comment 2 John W. Linville 2008-08-20 09:21:23 EDT
Actually rt2500 has been busted for a while.  There is an upstream patch that is supposed to fix it, but it hasn't made its way into fedora kernels yet.
Comment 3 John W. Linville 2008-08-20 09:22:41 EDT

*** This bug has been marked as a duplicate of bug 451422 ***
Comment 4 Mike 2008-08-20 15:10:41 EDT
Dan,

I do IRC That is how I have made it here. Tell me where you want to go and I will meet you there. I am using a supplicant config did you see the attachment? Also this worked before the upgrade. If you can suggest a config change I am all ears.



John, it worked fine till I updated. Are you saying that I am out of luck or I need to run the original kernel with no updates? What do you suppose the difference is?
Comment 5 Mike 2008-08-20 15:18:29 EDT
(In reply to comment #1)
> Best thing to do here is likely to try a supplicant config with the new kernel.
>  I can try to help lead you through that if you like.  Do you use IRC at all?

(In reply to comment #2)
> Actually rt2500 has been busted for a while.  There is an upstream patch that
> is supposed to fix it, but it hasn't made its way into fedora kernels yet.

Do you have any idea of when that will appear and do you have a suggestion on a new card that works with the latest fedora kernel?

Note You need to log in before you can comment on or make changes to this bug.