Bug 459582 - ipv6 connectivity is killed when removing an IPv6 address
ipv6 connectivity is killed when removing an IPv6 address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.2.z
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 08:42 EDT by Fabio Massimo Di Nitto
Modified: 2012-10-30 06:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:56:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2008-08-20 08:42:34 EDT
Description of problem:

IPv6 connectivity to a node is killed when removing a VIP v6.

Version-Release number of selected component (if applicable):

rgmanager-2.0.38-2.el5_2.1

How reproducible:

always.

Configure a cluster. Each node needs to have a v6 address. Setup a service that will create a VIP with a v6 address.
Start rgmanager.
make sure the service is working.
From another node, migrate the service.
The IPv6 connectivity to the node that was running the service is lost completely.

Steps to Reproduce:

Configure a cluster. Each node needs to have a v6 address. Setup a service that will create a VIP with a v6 address.
Start rgmanager.
make sure the service is working.
From another node, migrate the service.
The IPv6 connectivity to the node that was running the service is lost completely.
Comment 1 Fabio Massimo Di Nitto 2008-08-20 09:20:22 EDT
After additional testing, it all boils down to /sbin/ip.

there is no need of such complex setup to reproduce.

Configure a rhel5.2 (latest updates from rhn installed) to have an Ipv6 address configured the standard way at boot time (let say xxxx::100).

from an external machine ping6 that address to verify connectivity etc.

on the rhel box:

ip addr add dev eth0 xxxx::200

ping6 the extra address to verify is configured and working.

ip addr del dev eth0 xxxx::200

at this point all Ipv6 connectivity to the box is lost,

a service network restart is required to fix things around
Comment 2 Fabio Massimo Di Nitto 2008-08-28 04:02:24 EDT
Thanks to David Miller unlimited knowledge, we did nail this down to a problem on how rgmanager uses ip.

I am working on a patch since it's pretty straight forward but FYI the fact that we don't add a netmask when adding/removing an ipv6 address is bad.

Fabio
Comment 3 Fabio Massimo Di Nitto 2008-08-28 05:46:19 EDT
Lon,

I fixed this bug in 9bf373dbb03a185e49e36db5075d50352436b9c1 on our rhel5 branch.

Fabio
Comment 4 RHEL Product and Program Management 2008-08-28 09:52:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Lon Hohberger 2008-08-28 17:30:06 EDT
Setting to modified as Fabio fixed it already.
Comment 8 errata-xmlrpc 2009-01-20 15:56:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0101.html

Note You need to log in before you can comment on or make changes to this bug.