Bug 459583 - unable to process non-option command line file arguments
unable to process non-option command line file arguments
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: subtitleeditor (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On: 459792
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 08:43 EDT by Lubos Stanek
Modified: 2008-12-02 18:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 18:22:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Stanek 2008-08-20 08:43:34 EDT
Description of problem:
The application is not able to process files passed on the command line. It is not possible to launch the application via the file context menu in Nautilus.

Version-Release number of selected component (if applicable):
0.21.3 and higher

How reproducible:
Open the supported file's context menu in Nautilus and select Open in Subtitle Editor.
Launch the application from the command line with file parameters:
subtitleeditor <supported subtitle file>

Actual results:
Application starts without opening the file passed on the command line.

Expected results:
Application opens the file passed on the command line.

Additional info:
The application uses the glibmm's OptionEntry class with the G_OPTION_REMAINING flag to collect all non-option arguments (including the proper l10n of paths).
Although it should be fixed in glibmm-2.16.2 (currently in updates for FC9), it does not work. The minimal glibmm's release supporting this feature is 2.16.3.
It would be wise to update glibmm to the latest patch release from the stable series, currently 2.16.4 for the benefit of all applications.

See: http://bugzilla.gnome.org/show_bug.cgi?id=526831
Comment 1 Martin Sourada 2008-08-20 17:33:56 EDT
Thanks for the report and additional info. I can confirm the issue.
Comment 2 Lubos Stanek 2008-12-02 18:22:07 EST
The problem was fixed by the solution to the dependent bug report https://bugzilla.redhat.com/show_bug.cgi?id=459792.
Close it please if my permissions are not enough.

Note You need to log in before you can comment on or make changes to this bug.