Bug 459595 - Network Manager sets subnet mask incorrectly
Network Manager sets subnet mask incorrectly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 09:34 EDT by markm
Modified: 2008-11-02 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 17:23:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrectly set Subnet Mask by Network manager (27.17 KB, image/png)
2008-08-20 09:34 EDT, markm
no flags Details
Connected using DHCP (Subnet Mask is correctly set) (32.15 KB, image/png)
2008-08-20 09:42 EDT, markm
no flags Details

  None (edit)
Description markm 2008-08-20 09:34:05 EDT
Created attachment 314627 [details]
incorrectly set Subnet Mask by Network manager

Description of problem:

Network Manager sets subnet mask incorrectly - instead of in example 255.255.255.0 it saves 24.0.0.0

Version-Release number of selected component (if applicable):

NetworkManager-gnome 1:0.7.0-0.9.3.svn3675.fc9@i386
NetworkManager-glib 1:0.7.0-0.9.3.svn3675.fc9@i386
NetworkManager 1:0.7.0-0.9.3.svn3675.fc9@i386

How reproducible:

always

Steps to Reproduce:
1. Edit connection or create a new one
2. on IPv4 Settings tab select method 'Manual'
3. enter Address: 192.168.0.23, Netmask: 255.255.255.0, Gateway: 192.168.0.1
4. Save connection and connect
  
Actual results:

Connection information shows: "Subnet Mask: 24.0.0.0" which I believe makes some of the websites inaccessible for me.

Expected results:

Subnet Mask should be set to 255.255.255.0 as requested

Additional info:

I just got back from the trip, saw one bug, which I posted a week ago, "solved" by forcing downgrade, but it caused this bug to appear. I am trying to use Network manager, but it seems that wicd is currently the best option because it just works.
Comment 1 markm 2008-08-20 09:40:34 EDT
when connected via dhcp, sub net mask is correctly set and I can connect to all websites without any problem (although I cannot set my preferred dns).
Comment 2 markm 2008-08-20 09:42:24 EDT
Created attachment 314628 [details]
Connected using DHCP (Subnet Mask is correctly set)
Comment 3 Dan Williams 2008-11-02 17:23:54 EST
Should be fine now; you can enter either a CIDR prefix or a netmask in the box.  It'll always show what you entered as a CIDR prefix, but you can enter a netmask.

Note You need to log in before you can comment on or make changes to this bug.