Bug 45965 - ksu prints syslog messages to stderr
ksu prints syslog messages to stderr
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-26 00:30 EDT by Matthew Melvin
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 00:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Melvin 2001-06-26 00:30:29 EDT
Description of Problem:

ksu prints syslog messages to stderr even when using the -q (quiet) option.

[user@hostname ~]$ ksu -q
ksu[24196]: 'ksu root' authenticated user@REALM for user on /dev/pts/4
ksu[24196]: Account root: authorization for user@REALM successful
[root@hostname /home/user]#

This would seem to be due to LOG_AUTH being used as an option to the
openlog() call in krb5-1.2.2/src/clients/ksu/main.c instead of just a
facility...

#ifndef LOG_AUTH /* 4.2 syslog */
    openlog(prog_name, LOG_PID|LOG_NDELAY);
#else
    openlog(prog_name, LOG_PID | LOG_AUTH | LOG_NDELAY, LOG_AUTH);
#endif /* 4.2 syslog */

It should prolly just read...

#ifndef LOG_AUTH /* 4.2 syslog */
openlog(prog_name, LOG_PID|LOG_NDELAY);
#else
openlog(prog_name, LOG_PID | LOG_NDELAY, LOG_AUTH);
#endif /* 4.2 syslog */
Comment 1 Nalin Dahyabhai 2001-06-27 14:28:30 EDT
This will be changed in krb5-1.2.2-9 and later.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.