Bug 459668 - virt-manager can't connect to localhost qemu
virt-manager can't connect to localhost qemu
Status: CLOSED DUPLICATE of bug 458522
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 19:22 EDT by James Morris
Modified: 2008-08-21 04:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 04:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2008-08-20 19:22:57 EDT
Description of problem:

virt-manager seems unable to connect to the localhost qemu system.

Version-Release number of selected component (if applicable):

virt-manager-0.5.4-4.fc9.x86_64

How reproducible:

Always

Steps to Reproduce:
1. launch virt-manager
2. double click on localhost qemu system
3.
  
Actual results:

Status changes to "connecting" and stays like that for a while, then the window stops redrawing.

Expected results:

A new window with the VMs listed for localhost.

Additional info:

Attaching strace after the window stops redrawing shows:

# strace -f -p 3031
Process 3052 attached with 2 threads - interrupt to quit
[pid  3052] futex(0x214a530, FUTEX_WAIT_PRIVATE, 2, NULL <unfinished ...>
[pid  3031] futex(0x2502b10, FUTEX_WAIT_PRIVATE, 0, NULL

This was working fine with F9 stable updates, but broke when I updated to rawhide.

virsh based operation still seems to work.

Note also that I'm doing this over VNC.
Comment 1 Daniel Berrange 2008-08-21 04:14:40 EDT
pygobject is trashing the python interpeter thread state. See bug 458522

*** This bug has been marked as a duplicate of bug 458522 ***

Note You need to log in before you can comment on or make changes to this bug.