Bug 459681 - cannot more compile madwifi
cannot more compile madwifi
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-21 01:55 EDT by Claude Frantz
Modified: 2008-08-22 05:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 11:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The ticket opened at the madwifi wiki (31 bytes, text/plain)
2008-08-21 01:55 EDT, Claude Frantz
no flags Details

  None (edit)
Description Claude Frantz 2008-08-21 01:55:32 EDT
Created attachment 314683 [details]
The ticket opened at the madwifi wiki

Description of problem:

The problem is related to madwifi, the ticket is here https://madwifi.org/ticket/2081. There, mrenzmann write:

Well, the "original" issue as such was introduced by changes to the wireless extensions that went into 2.6.26. We have a fix for this in trunk for vanilla kernel 2.6.26 (see #2022). Fedora backported the WE-changes to their 2.6.25 kernel, causing the problem described in this ticket.

It should be possible to backport the fix from trunk and make it apply to Fedora's 2.6.25 kernel. However, Fedora users struck by this issue would be required to manually apply the patch themselves; as explained above it's not easily possible to commit this patch to our repository, because it would break compatibility for all non-Fedora users. 

[...]

Because of this problem madwifi cannot more be used on Fedora because it cannot more be compiled. ath5k is not a valid alternative because it do not work well in many installations were madwifi worked.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John W. Linville 2008-08-21 11:14:31 EDT
Sorry, I'm not introducing kernel churn just to please madwifi.  FWIW, it looks like it wouldn't take much to hack the madwifi sources if you insist on using it.

OTOH, I recommend that you use ath5k and open bugs for whatever issues you find.  It (along w/ ath9k) is the future of Atheros support in the kernel.
Comment 2 Claude Frantz 2008-08-22 05:40:15 EDT
You are probably right, John ! But now, I'm not more able to run the Atheros hardware and I will probably have to change it. Debugging the ath5k software is a too complex task for me. The problem I have encountred is not very simple.

Note You need to log in before you can comment on or make changes to this bug.