Bug 459707 - gnome-power-manager routinely segfaults
gnome-power-manager routinely segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-08-21 10:36 EDT by Jarod Wilson
Modified: 2008-08-23 19:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 19:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from gnome-power-manager --verbose --no-daemon (20.05 KB, text/plain)
2008-08-21 10:36 EDT, Jarod Wilson
no flags Details
patch (547 bytes, patch)
2008-08-21 10:50 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Jarod Wilson 2008-08-21 10:36:11 EDT
Created attachment 314700 [details]
Output from gnome-power-manager --verbose --no-daemon

Description of problem:
Pretty much without fail, gnome-power-manager segfaults on me within a short time of starting up.

Attached is the output from starting up g-p-m with --verbose and --no-daemon. Inline right here is the gdb backtrace:

----8<----
(gdb) run --no-daemon
Starting program: /usr/bin/gnome-power-manager --no-daemon
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff7fae7f0 (LWP 15659)]
Detaching after fork from child process 15668.

** (gnome-power-manager:15659): CRITICAL **: gpm_cell_array_get_cell: assertion`GPM_IS_CELL_ARRAY (cell_array)' failed

** (gnome-power-manager:15659): CRITICAL **: gpm_cell_get_unit: assertion `cell!= NULL' failed

Program received signal SIGSEGV, Segmentation fault.
gpm_cell_array_update (cell_array=0x8474b0) at gpm-cell-array.c:288
288                     if (unit_temp->is_present == FALSE) {
Missing separate debuginfos, use: [...list redacted...]
----8<----


Version-Release number of selected component (if applicable):
gnome-power-manager-2.23.6-1.fc10.x86_64


How reproducible:
Start gnome-power-manager on my t61, watch it go boom.
Comment 1 Richard Hughes 2008-08-21 10:41:01 EDT
Already fixed in cvs, i just can't build packages :-(.
Comment 2 Jarod Wilson 2008-08-21 10:43:35 EDT
Oops, didn't actually put the bt in. Sounds like there's no need, since its already fixed, but just the same here it is for posterity... I'll build out of cvs and verify that it fixes things here though.


(gdb) bt full
#0  gpm_cell_array_update (cell_array=0x8474b0) at gpm-cell-array.c:288
        unit = (GpmCellUnit *) 0x848538
        unit_temp = <value optimized out>
        cell = <value optimized out>
        num_present = 0
        length = 1936024677
        i = 0
        __FUNCTION__ = "gpm_cell_array_update"
#1  0x00000000004111d0 in gpm_cell_percent_changed_cb (
    cell=<value optimized out>, percent=4160415728, cell_array=0x20)
    at gpm-cell-array.c:597
        __FUNCTION__ = "gpm_cell_percent_changed_cb"
#2  0x000000371200b7fd in IA__g_closure_invoke (closure=<value optimized out>,
    return_value=<value optimized out>, n_param_values=<value optimized out>,
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:767
        marshal = <value optimized out>
        marshal_data = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#3  0x00000037120225b0 in signal_emit_unlocked_R (node=<value optimized out>,
    detail=<value optimized out>, instance=<value optimized out>,
    emission_return=<value optimized out>,
    instance_and_params=<value optimized out>) at gsignal.c:3244
        tmp = <value optimized out>
        handler = <value optimized out>
        accumulator = <value optimized out>
        emission = Could not find the frame base for "signal_emit_unlocked_R".
Comment 3 Jarod Wilson 2008-08-21 10:45:11 EDT
Or perhaps I won't build out of cvs, since it seems that cvs is offline again... :\

Don't suppose you could attach the patch here? :)
Comment 4 Richard Hughes 2008-08-21 10:50:47 EDT
Created attachment 314702 [details]
patch
Comment 5 Jarod Wilson 2008-08-21 11:03:41 EDT
Muchas gracias, building now...
Comment 6 Jarod Wilson 2008-08-21 15:32:17 EDT
Build w/that patch has lasted quite a bit longer than it has in quite a while, looks golden.
Comment 7 Matthias Clasen 2008-08-23 19:46:59 EDT
Patch is in rawhide

Note You need to log in before you can comment on or make changes to this bug.