Bug 459769 - Old installation not detected, only allows fresh install
Old installation not detected, only allows fresh install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 00:32 EDT by Casper van Donderen
Modified: 2008-08-26 13:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 13:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casper van Donderen 2008-08-22 00:32:09 EDT
Description of problem:
After doing a fresh FC7 installation on a company desktop I wanted to upgrade to FC9 (company only supports 7, so no FC9 install done). Firstly I completely updated the FC7 installation. Then I installed preupgrade and started the upgrade.
After waiting for the 1.1GB to download and doing the '/'-path in my grub menu.lst I rebooted.

Anaconda starts, but does not detect the old FC7 installation and skips the 'Install/Upgrade' selection screen(<a href="http://images.howtoforge.com/images/upgrade_f8_f9/big/fb2.jpg">http://images.howtoforge.com/images/upgrade_f8_f9/big/fb2.jpg</a> )and continues as if I have chosen the fresh installation option.

I do not know if this is a Anaconda bug or a preupgrade bug. I assume it is an Anaconda bug and Anaconda not being able to detect my old partition.

I have not tested if the same happens when using a DVD since it is to big to download (max 15KB/s connection)

Version-Release number of selected component (if applicable):
0.9.3-3.fc7

How reproducible:
- Install FC7
- update FC7
- install preupgrade 
- start preupgrade
  
Actual results:
Anaconda starts and gives the options to do a fresh install: select hostname, timezone, select root password, setup partitions

Expected results:
The option to do an upgrade and start the upgrade of the system

Additional info:

df -h output:
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda6             9.7G  4.3G  5.0G  46% /
tmpfs                 756M     0  756M   0% /dev/shm
/dev/sda8              22G  184M   21G   1% /home

menu.lst entry:
title Upgrade to Fedora 9 (Sulphur)
        kernel /boot/upgrade/vmlinuz preupgrade lang=en_US.UTF-8 keymap=us stage2=hd:sda6:/boot/upgrade/stage2.img
method=http://ftp.iitm.ac.in/fedora/releases/9/Fedora/i386/os
        initrd /boot/upgrade/initrd.img
Comment 1 Andy Lindeberg 2008-08-26 13:05:51 EDT
We don't support upgrading directly from F7 to F9. Please try upgrading to F8 first, and let us know if you have the same problem.

Note You need to log in before you can comment on or make changes to this bug.