Bug 459811 - Request to include em64t arch support
Request to include em64t arch support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sebastian Skracic
venkat
US=4854
:
: 453832 (view as bug list)
Depends On:
Blocks: 453832 642708
  Show dependency treegraph
 
Reported: 2008-08-22 11:41 EDT by Pradeep Kilambi
Modified: 2014-09-19 02:04 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 08:42:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
em64t (197.75 KB, image/png)
2010-10-20 14:42 EDT, venkat
no flags Details

  None (edit)
Description Pradeep Kilambi 2008-08-22 11:41:14 EDT
Description of problem:

RHN currently doesn't support em64t arch. This is causing package profile syncs to fail with em64t arch package clients. We jus need to make sure the db treats em64t as a valid arch and we should be good. Should be a easy fix.

Thanks,
Comment 2 Clifford Perry 2009-02-20 17:18:55 EST
*** Bug 453832 has been marked as a duplicate of this bug. ***
Comment 3 Mike Hanby 2009-07-09 17:29:46 EDT
Has there been any work around identified for this issue?

I have many systems that have the following Intel compiler packages installed, and all of them are failing to update from the satellite because they are unable to complete an 'up2date --package' or equivalent:

intel-iidbe101015-10.1.015-1
intel-icce101015-10.1.015-1
intel-iforte101015-10.1.015-1
intel-mkl100014-10.0p-014
intel-isubhe101015-10.1.015-1

Unfortunately the compilers are used regularly and can't be removed. Also, I can't seem to find the "rhn user story: 42956" listed above, the link is dead and searching doesn't find anything.

This is with
up2date-4.8.1-33.el4

Hoping someone has a workaround. Thanks
Comment 5 Weqaar A. Janjua 2009-09-16 10:46:58 EDT
EM64T is just a variant of X86_64, you seem to have ICC (Intel C Compiler) for EM64T (specific) installed, see output from:

rpm -qa --qf "%{n}-%{arch}\n"|grep em64t

The right way to go about is to edit the file: 
“/usr/share/rhn/up2date_client/rpmUtils.py” 

Insert the line, in first few import statements:

import platform

Edit line 159 of that file to include the un-recognized architecture (you won't find RPMs for EM64T) - for remove “arch” rpm TAG from package list, in our case “em64t”:

if arch != platform.machine():
    pkg_list.append([name, version, release, epoch])
elif arch:
    pkg_list.append([name, version, release, epoch, arch])

(take care of the correct indentation, its Python!)

Note that this may be overriden with the update to this file.
Comment 11 Sebastian Skracic 2010-10-14 06:40:48 EDT
dbchange provided in cc2e23582be4fe3218ea986988942644850be8e2.
Comment 12 Sebastian Skracic 2010-10-14 07:25:05 EDT
dbchange successfully applied to webdev.
Comment 14 Sebastian Skracic 2010-10-20 09:14:19 EDT
The rest of the dbchange is in 70b6ba9d6af2bb96cd04d6356820c9f174dd44ef, also available on webdev.
Comment 15 venkat 2010-10-20 14:42:35 EDT
Created attachment 454640 [details]
em64t

emt64t
Comment 16 venkat 2010-10-20 14:44:04 EDT
verified in webdev with the following system : voola.fjs-0-06.10202010

and the attchment shows the package with em64t architecture.
Comment 17 Karl Abbott 2011-01-13 08:39:31 EST
venkat,

When will this change go live?

Karl
Comment 18 venkat 2011-01-14 08:41:11 EST
it went out as part of 5.2.6 release

Note You need to log in before you can comment on or make changes to this bug.