Bug 459815 - Running RHEL5 in VMware 1.0.6 (under Windows XP) with a software bridge causes IPtables to drop ESTABLISHED connections
Running RHEL5 in VMware 1.0.6 (under Windows XP) with a software bridge cause...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Jiri Olsa
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 12:08 EDT by Pete Philips
Modified: 2010-06-07 06:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 06:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Philips 2008-08-22 12:08:42 EDT
Description of problem:

A RHEL5 guest under VMware 1.0.6 running on Windows XP will drop packets that should normally be ACCEPTED by the ESTABLISHED rule.

Version-Release number of selected component (if applicable):

RHEL 5.2 + latest errata
VMware 1.0.6

How reproducible:

Easily

Steps to Reproduce:

1. Install a RHEL5 guest OS under VMware-server running on Windows XP.
2. In VMware configure 3 Ethernet interfaces using "bridged" mode.
3. Boot the RHEL5 guest
4. In the guest OS, configure 3 ethernet interfaces, eth0-eth2. eth0 and eth1 should be up but with no IP address. eth2 should have an IP address.
5. Create a bridge br0 with interfaces eth0 and eth1.
6. Use the default IPtables ruleset which uses an ESTABLISHED rule.
7. Run a script which repeatedly scp's a 1k file to a remote host and keeps a count of how many it's done.
8. If the bridge is down then this will carry on forever.
9. If the bridge is up then it will hang after less than 1000 iterations.
  
Actual results:

Script hangs.


Expected results:

Script continues for ever.

Additional info:

It appears that conntrack is failing and packets that should be ESTABLISHED are in fact being dropped.
Comment 1 Herbert Xu 2009-02-23 06:56:13 EST
Do you have bridge netfilter enabled? If so please try disabling it.  Thanks!
Comment 2 Jiri Olsa 2010-05-30 17:10:01 EDT
hi,
can we close this bug? I've got no answer for quite some time,
I'll close this bug next week if I dont hear from you

wbr,
jirka
Comment 3 Jiri Olsa 2010-06-07 06:24:50 EDT
I've got no response, closing as not a bug

Note You need to log in before you can comment on or make changes to this bug.