Bug 459817 - groupmems does not add or remove users propery
groupmems does not add or remove users propery
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
: 459825 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 12:54 EDT by chris
Modified: 2008-09-10 03:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 05:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris 2008-08-22 12:54:01 EDT
Description of problem: groupmems does not add or remove users propery

1) groupmems -g groupname -d username does not remove the user from the group.

2) groupmems -g groupname -a username gives a Segmentaion Fault Error when adding when adding an addition user to groups that have two or more users.

Version-Release number of selected component (if applicable):
shadow-utils-2:4.0.18.1-22.fc8.i386


How reproducible:

constistantly Reproducible


Steps to Reproduce:
1)groupmems -g groupname -d username does not remove the user from the group.
     A) if groupname contains users tom, dick, harry 
     B) # groupmems -g groupname -l   => tom, dick, harry
     C) # groupmens -g groupname -d dick   
     D) # groupmems -g groupname -l   => tom, dick, harry

2) groupmems -g groupname -a username gives a Segmentaion Fault Error when adding when adding an addition user to groups that have two or more users.

     A) if groupname contains users tom and you want to add users dick and harry
     B) # groupmens -g groupname -a dick
     C) # groupmems -g groupname -l   => tom, dick, 
     D) # groupmens -g groupname -a harry  => Segmentation Fault
    

Actual results:
See doc on steps to reproduce
Expected results:

See doc on steps to reproduce
Additional info:
Comment 1 Peter Vrabec 2008-09-02 05:03:50 EDT
*** Bug 459825 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2008-09-02 05:14:51 EDT
shadow-utils-4.1.1-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/shadow-utils-4.1.1-4.fc9
Comment 3 Peter Vrabec 2008-09-02 05:19:03 EDT
Feel free to reopen this bug report, if shadow-utils-4.1.1-4.fc9 doesn't fix the issue.
Comment 4 Fedora Update System 2008-09-10 03:01:56 EDT
shadow-utils-4.1.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.