Bug 459837 - AttributeError: 'str' object has no attribute 'epoch'
AttributeError: 'str' object has no attribute 'epoch'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 16:21 EDT by Sebastian Vahl
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.2.19-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 11:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-08-22 16:21:47 EDT
Description of problem:
The creation of live images using livecd-fedora-9-desktop.ks or livecd-fedora-9-kde.ks fails with a python traceback:

[...]
filespec_eval:  hash table stats: 12 elements, 11/65536 buckets used, longest chain length 2
Retrieving http://ftp.uni-bayreuth.de/linux/fedora/linux/releases/9/Everything/x86_64/os/repodata/repomd.xml ...OK
Retrieving http://ftp.uni-bayreuth.de/linux/fedora/linux/releases/9/Everything/x86_64/os/repodata/primary.sqlite.bz2 ...OK
Retrieving http://ftp.uni-kl.de/pub/linux/fedora/linux/updates/9/x86_64/repodata/repomd.xml ...OK
Retrieving http://ftp.uni-kl.de/pub/linux/fedora/linux/updates/9/x86_64/repodata/primary.sqlite.bz2 ...OK
Retrieving http://ftp.uni-bayreuth.de/linux/fedora/linux/releases/9/Everything/x86_64/os/repodata/Fedora-9-comps.xml.gz ...OK
Retrieving http://ftp.uni-kl.de/pub/linux/fedora/linux/updates/9/x86_64/repodata/comps-f9.xml ...OK
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 132, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 115, in main
    creator.install()
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 638, in install
    self.__deselect_packages(ayum)
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 595, in __deselect_packages
    ayum.deselectPackage(pkg)
  File "/usr/lib/python2.5/site-packages/imgcreate/yuminst.py", line 102, in deselectPackage
    if x in pkgs:
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 265, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name == other.name:
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 48, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.version, po2.release)
AttributeError: 'str' object has no attribute 'epoch'


Version-Release number of selected component (if applicable):
livecd-tools-017.1-1.fc9.x86_64

How reproducible:
everytime

Steps to Reproduce:
1a. livecd-creator -c /usr/share/livecd-tools/livecd-fedora-9-desktop.ks

or

1b. livecd-creator -c /usr/share/livecd-tools/livecd-fedora-9-kde.ks
  
Actual results:
traceback

Expected results:
no failure
Comment 1 Jeremy Katz 2008-08-26 23:11:23 EDT
This was due to an API change in 3.2.18, but I thought an update went out fixing it up
Comment 2 James Antill 2008-08-27 01:15:27 EDT
 Due to recent events 3.2.19 has only just been released, so I'd assume it'll hit updates-testing in the next day or so.

Note You need to log in before you can comment on or make changes to this bug.