Bug 459853 - orage fails to do anything
orage fails to do anything
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: orage (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 21:20 EDT by Lonni J Friedman
Modified: 2008-10-09 20:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 20:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2008-08-22 21:20:17 EDT
Description of problem:
Starting orage for the first time on Fedora9, no windows ever appear, it just sits running seemingly doing nothing.  I'm seeing this behavior on two different Fedora9 systems.  If I start it from a terminal window, I see the following output:
#########
$ orage 
** Message: Orage **: Too small icon size, using static icon

** Message: Orage **: Build alarm list: Processed 0 events.
	Found 0 alarms of which 0 are active. (Searched 0 recurring alarms.)
#########

Version-Release number of selected component (if applicable):
orage-4.4.2-3.fc9.i386

How reproducible:
100% of the time

Steps to Reproduce:
1. run 'orage'
2. no windows ever appear
  
Actual results:
no windows ever appear

Expected results:
orage window with calendar appears
Comment 1 Kevin Fenzi 2008-08-22 21:42:47 EDT
Odd. It sounds like orage is having trouble talking to your mcs-manager process. 

I assume you are in a Xfce session when you run it? 
(It requires xfce-mcs-manager running). 

If you start it, logout (saving session) and login again does it start working? 

I will try and duplicate here.
Comment 2 Lonni J Friedman 2008-08-22 22:23:40 EDT
Yes, I'm logged into an XFCE session on both systems.  

I do have an xfce-mcs-manager process running (since I logged into XFCE back on Aug 15).  I left orage running, logged out of XFCE, then back in, but nothing has improved or changed.
Comment 3 Kevin Fenzi 2008-10-09 20:43:38 EDT
Sorry for the delay here in getting back to you. ;( 

Several things to try: 

1. Does this happen if you create a new user and login as them? 

2. Do you have a systray in one of your panels? Orage wants to appear in a systray. 

3. As as last resort, Can you try doing a 'strace -o /tmp/trace.out -f orage' and attach the trace.out file?

orage comes up fine for me here, so I am not sure whats going on. ;(
Comment 4 Lonni J Friedman 2008-10-09 20:52:33 EDT
Oddly, it works now.  Marking fix-unknown.

Note You need to log in before you can comment on or make changes to this bug.