Bug 459861 - conduit does not work with pygobject2-2.15.x
conduit does not work with pygobject2-2.15.x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygobject2 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-23 00:31 EDT by Michel Alexandre Salim
Modified: 2009-06-29 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: pygobject2-2.16.1-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 00:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 549066 None None None Never

  None (edit)
Description Michel Alexandre Salim 2008-08-23 00:31:59 EDT
Description of problem:
conduit (0.3.11.1 and 0.3.13) works fine against pygobject2-2.14.2 from F9. Against pygobject2-2.15.2 from Rawhide, however, it failed with an assertion error within the Python interpreter:

[DBus                ][DEBUG  ] DBus Exported: / (DBus.py:127)
[DBus                ][DEBUG  ] DBus Exported: /syncset/gui (DBus.py:127)
[DBus                ][DEBUG  ] DBus Exported: /syncset/dbus (DBus.py:127)
[modules.Network     ][DEBUG  ] Resolved conduit service berlin on berlin.local - 192.168.1.50:3400
Extra Info: ['version=0.3.11.1'] (Peers.py:242)
[modules.Network     ][DEBUG  ] Remote host 'http://berlin.local' detected (Client.py:49)
python: Python/ceval.c:2624: PyEval_EvalCodeEx: Assertion `tstate != ((void *)0)' failed.

Version-Release number of selected component (if applicable):
pygobject2-2.15.2-3.fc10
conduit-0.3.11.1-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. yum install conduit
2. conduit
  
Actual results:
Error message above

Expected results:
Should work (downgrading pygobject2 to the version from F9-updates allows conduit to work; conduit 0.3.13 also works with the older pygobject2)

Additional info:
Same problem occurs with and without the threading patch applied in 2.15.2-3.fc10
Comment 1 Bug Zapper 2008-11-25 21:51:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthew Barnes 2009-06-29 00:50:57 EDT
This seems to be working better on Fedora 11 using:

  conduit-0.3.15-6.fc11.noarch
  pygobject2-2.16.1-4.fc11.i586

Feel free to reopen this bug if you're still encountering problems.

Note You need to log in before you can comment on or make changes to this bug.