Bug 45987 - removing --with-ipv4-default from openssh
removing --with-ipv4-default from openssh
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh (Show other bugs)
1.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-26 04:12 EDT by Pekka Savola
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 04:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2001-06-26 04:12:05 EDT
WIth current glibc's (tested on RHL62 and RHL71), it's pretty safe to
remove
'--with-ipv4-default' from openssh compile-time options.

This makes it so that when you connect like 'ssh some.box' ssh will first
do a AAAA
(IPv6) DNS lookup, and after that fails (~0.1 sec or less), does the normal
A query.

Some other vendors have also been enabling this, e.g. Mandrake apparently.

In practise, all this means is you don't have to use 'scp -6' or 'ssh -6'
when connecting
to ipv6 hosts.

Only apparent side-effect I have noticed (apart from AAAA query), on a box
where there is no IPv6 is:

Jun 26 10:45:23 pajulintu modprobe: modprobe: Can't locate module net-pf-10

when sshd is started.   This is good because if there would be 'alias
net-pf-10 ipv6' 
in /etc/modules.conf, sshd would autoload it which wouldn't be the intent
(the alias is added by initscripts if NETWORKING_IPV6 is set)
Comment 1 Nalin Dahyabhai 2001-09-06 08:52:34 EDT
This change will be made for 7.x systems in 2.9p2-7 and later.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.