Bug 459889 - SCIM is not working in KDE 4.1, only English text is coming not the other input languages
SCIM is not working in KDE 4.1, only English text is coming not the other inp...
Status: CLOSED DUPLICATE of bug 457635
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-23 15:37 EDT by kushaldas@gmail.com
Modified: 2008-08-25 00:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 00:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kushaldas@gmail.com 2008-08-23 15:37:57 EDT
Description of problem: SCIM  is not working in KDE 4.1 I can only input English, other languages like Bengali is not coming.


Version-Release number of selected component (if applicable): scim-1.4.7-23


How reproducible: Login in KDE 4.1 desktop with scim installed (which is working in Gnome desktop)

Steps to Reproduce:
1. Goto any text input box, firefox or xchat
2. Press Ctrl + spacebar to change scim input method 
3. Or click on the scim system tray icon and select any other language input
4. Type something in the text box
  
Actual results: Only English text is coming.

Expected results: Input should have come in the selected input language not in English.
Comment 1 Jens Petersen 2008-08-24 23:14:03 EDT
(I guess kde 4.1 has not been pushed yet to F9 updates or even testing?
Perhaps we should move this to rawhide?)

I am not able to reproduce this in rawhide FWIW.
Comment 2 Jens Petersen 2008-08-24 23:20:14 EDT
Kushal, probably need a bit more information from you.

What is your output of "imsettings-info SCIM"?
Comment 3 Rex Dieter 2008-08-25 00:44:03 EDT
Re: comment #1
kde-4.1.0 is currently in updates-testing, queue'd for stable pending next push.
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 4 Akira TAGOH 2008-08-25 00:44:28 EDT
We don't support any applications on KDE yet, particularly which is linking GTK+. right now KDE 4 doesn't have a XSETTINGS manager that imsettings requires to work. and GTK+ applications, including firefox needs XSETTINGS to get a proper immodule settings through imsettings. as you said, you saw this issue on firefox and xchat, I don't see any other reason why you got this issue.

For a workaround, you could have "export GTK_IM_MODULE=scim-bridge" in your .bashrc or wherever. plese note that you will have to remove it once the bug is gone. otherwise you'll miss the entire features in imsettings in the future.

*** This bug has been marked as a duplicate of bug 457635 ***

Note You need to log in before you can comment on or make changes to this bug.